"Saving file" makes all other moz-windows z-axis dependant

VERIFIED WORKSFORME

Status

()

Core
XUL
P3
normal
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: R.K.Aa., Assigned: Dan M)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
"saving file" dialog insists on being one layer ahead of all other moz windows.
This is annoying, and cause some odd behaviour in coexistance with other
applications.


To reproduce:

-start a ftp download from a navigator window

-place the "Saving File" dialog beside the browser window

-open a third hand application.

-let that cover *all* of download dialog and *most* of navigator window,
 but leave the "File" menu visible

-now try raise the navigator window to top: Can't be done.

-click once on "File" menuitem: Dropdown menu appears

-now move mouse to the right, along "invisible" menu-bar: Dropdown menus      
appear *on top of third party app*!

-Return to "File" menu, and click "new navigator window": It will open behind
the third party app.


No moz windows can be brought to front of the third party app untill "Saving
file" dialog is brought to front first.

Expected behaviour:
Be able to raise other Moz windows to top of "foreign apps" without having to
raise the download dialog first. Is there a reason why the dowload window stays
on top in the first place?


This bug hardly "new" but i couldn't find it.
Currently tested on linux build 2000-080108

Comment 1

18 years ago
XPApps Gui Features. 
Component: Browser-General → XP Apps: GUI Features

Comment 2

18 years ago
and reassign
Assignee: asa → ben
QA Contact: doronr → sairuh
Netscape Nav Triage Team - reassigning to danm, changing component to xp 
toolkit.
Assignee: ben → danm
Component: XP Apps: GUI Features → XP Toolkit/Widgets
(Reporter)

Comment 4

18 years ago
2001010908
seems the box behaves OK now. This MAY have been wm dependant also. Have
upgraded to sawfish 0.35 in the meanwhile. WFM anyway.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
QA Contact: sairuh → jrgm

Comment 5

18 years ago
working for me too, afaict. Perhaps it was the WM, but reopen (of course) if
you can reproduce this behaviour. Thanks.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.