links from chatzilla and throbber open in current tab

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: kavalec74, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090109 SeaMonkey/2.0a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090109 SeaMonkey/2.0a3pre

prefs set:
Link open behavior: open links in a new tabs in current window
Links from other applications: open links in a new tabs in current window

Link opened from chatzilla open in the current tab.
Clicking throbber icon open in the current tab.


Reproducible: Always

Steps to Reproduce:
1. Open a web page in the browser for example http://google.com
2. enter a message containg a url in chatzilla for example http://mozilla.org
3. left click it / click on the throbber
4. both links will open in current tab replacing google.com
Actual Results:  
Both links: http://mozilla.org and http://www.seamonkey-project.org/ - throbber link will replace content of current tab - google.com 

Expected Results:  
Both links: http://mozilla.org - in CZ and http://www.seamonkey-project.org/ - throbber-link will open in a new tab in current window.
Version: unspecified → Trunk

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090119 SeaMonkey/2.0a3pre

I confirmed this bug on chatzilla on SeaMonkey (20090119 SeaMonkey/2.0a3pre)

Open link from SeaMonkey mail client is OK.
Assignee: nobody → rginda
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → ChatZilla
Ever confirmed: true
OS: Linux → All
Product: SeaMonkey → Other Applications
QA Contact: tabbed-browser → chatzilla
Version: Trunk → unspecified

Comment 2

10 years ago
This is not a bug - we deliberately disregard those preferences because, for various reasons, we have our own.

Comment 3

10 years ago
Per comment #2 --> INVALID
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

10 years ago
Then stop "deliberately disregard those preferences" and fix the bug. Obviously it is a bug.

"Various reasons"? - Could you list some of them, please?

Sorry, but #2 sounds like total ****

Comment 5

10 years ago
You can easily change the way ChatZilla opens links - it just happens to be disjoin from Firefox's own options. If you don't like the default, change it. (The next version of ChatZilla will default to using new tabs.)
(Reporter)

Comment 6

10 years ago
Thank you Ross :)

But where can I change it? I have set both preferences, as I explaned above. The throbber-link does the same. It is not CZ-only bug.
I use seamonkey by the way.

Comment 7

10 years ago
In ChatZilla's preferences (ChatZilla menu in ChatZilla, or via the ChatZilla page in SeaMonkey's preferences), select Global Settings and go to the Global tab - about half-way down are the link preferences. You just need to change the "Normal click" setting to "goto-url-newtab" (and I'd agree it's not an ideal UI, but that's a whole other story).

You'll have to file a separate bug for the throbber (one issue per bug as best as possible), especially as it has no relationship to ChatZilla in terms of the code involved.
(Reporter)

Comment 8

10 years ago
Nice, I found it :) sorry, I did not see this pref / did not know about it. CZ was from the beginning part of Mozilla. I meant SM-prefs would have influence on CZ as well, so that I did not look for the pref in CZ. I do mean CZ have a "special" possition between extensions. I mean it should become fixed part of SM the same way as compozer.
You need to log in before you can comment on or make changes to this bug.