Permissions broken on aus2-staging, breaking nightly updates

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: standard8, Assigned: aravind)

Tracking

Details

(Reporter)

Description

10 years ago
+++ This bug was initially created as a clone of Bug #472817 +++

This seems related to bug 472817. All of Thunderbird nightly builds have failed to upload update snippets for today's builds.

From the log:

Starting snippet generation
Generating complete update in: build/objdir-tb/mozilla/dist/update/complete.update.snippet
Snippet generation complete

Could not chdir to home directory /home/tbirdbld: Permission denied
bash: /home/tbirdbld/.bashrc: Permission denied
mkdir: cannot create directory `/opt/aus2/build/0/Thunderbird/trunk/Linux_x86-gcc3/20090110031334': Permission denied

http://tinderbox.mozilla.org/showlog.cgi?log=Thunderbird3.0/1231585200.1231590584.24051.gz
(Assignee)

Comment 1

10 years ago
I fixed the perms on the box, please let me know if you continue to have problems.  I apologize for the screw up.
Assignee: server-ops → aravind
Got something similar with the ffxbld account:

rsync: recv_generator: mkdir "/opt/aus2/incoming/2/Firefox/mozilla-1.9.1/Darwin_Universal-gcc3/20090110020329" failed: Permission de
nied (13)

Also seeing that fwenzel owns all of /opt/aus2/incoming/2/Thunderbird, and rcampbell the Firefox equivalent.
(Reporter)

Comment 3

10 years ago
We've just tried respining the Thunderbird nightlies, (and as Nick's comments implied there could be) there is still the same issue with them uploading.
/opt/aus2/build/0 should be fixed up now, so tinderboxes should be able to push up OK. Still working on /opt/aus2/incoming/2 (so that the partial update generator can push), taking this chance to clean up a bit.
Summary: Permissions broken for Thunderbird on aus2-staging, breaking nightly updates → Permissions broken on aus2-staging, breaking nightly updates
(Reporter)

Comment 5

10 years ago
Thanks for the update, I'm not going to try and push any more nightlies through at the moment - will let them kick in normally tomorrow and see what happens.
(In reply to comment #4)
> /opt/aus2/build/0 should be fixed up now, so tinderboxes should be able to push
> up OK. Still working on /opt/aus2/incoming/2 (so that the partial update
> generator can push), taking this chance to clean up a bit.

Does this fix bug 472984 as well?
Duplicate of this bug: 472984
(In reply to comment #7)
> *** Bug 472984 has been marked as a duplicate of this bug. ***

Now that I finished cleaning up /opt/aus2/incoming/2 that is fixed.

The partial generator is running again. Firefox 2.0 & 3.0 and Thunderbird 2.0 will skip the 20080110 nightlies and go from 20080109 to 20080111.

Please reopen if I missed anything.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

10 years ago
This has worked on the Thunderbird nightlies today (at least Mac updates work,  and all builds are green), thanks for fixing.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.