Firefox installer does not request administrative privileges

RESOLVED DUPLICATE of bug 404541

Status

()

Firefox
Installer
RESOLVED DUPLICATE of bug 404541
10 years ago
10 years ago

People

(Reporter: pyrates18, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Starting in windows 7, Microsoft appears to have removed the detection of the word setup in any executable which would normally make it run as administrator when ran.  Firefox 3.05 when the installer is launched is expecting this and doesn't get it, therefore it just runs as a regular user and when it gets to the part where it tries to select which directory to install to, it says "You don't have write access to the installation directory.  Click OK to select a different directory.  You then have to cancel the installation and right click on it and select run as administrator.

Reproducible: Always

Steps to Reproduce:
1.  Install windows 7 beta 1.
2.  Download firefox 3.05.
3.  Open up Firefox Setup 3.0.5.exe.
Actual Results:  
The installer runs without prompting you for administrative privileges and therefore fails when it gets to the part where it selects the installation directory.

Expected Results:  
I should be prompted immediately since the setup executable should tell Windows that it needs administrative privileges.

I know this is beta software, but other then this Firefox 3.05 runs just fine in Windows 7.

Also firefox when it is being installed should not launch automatically as it will launch with administrative privileges when it doesn't need them normally.
We actually add a manifest to the installer to prevent the auto-detection so that isn't the problem. Is your user account a member of the admin group and do you have UAC turned on? If not then this is a duplicate of bug 404541
(Reporter)

Comment 2

10 years ago
No my user is not a member of the admin account and I do have UAC turned on.  I will add my input then to that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404541
You need to log in before you can comment on or make changes to this bug.