Cant undo paste operations with rich text

RESOLVED DUPLICATE of bug 261392

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 261392
10 years ago
9 years ago

People

(Reporter: Steve McMillen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081202 SeaMonkey/2.0a2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090108 Shredder/3.0b2pre

Note: This bug impacts both SeaMonkey Composer and Thunderbird Compose window.

If I paste rich text into the html edit region and try to undo the operation, nothing happens.  All undo tasks, including the recent rich text operation, fail to work.

In contrast, if I paste plain text (or use Paste w/o Formatting Menu item to force paste plain text), then undo works as expected.

I've only tried this on Mac OS X.  Let me know if needed and I'll go ahead and setup the right apps on a windows or linux env to test there.


Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird (latest 3.0b2pre release)
2. Start composing an email (using html formatting)
3. Copy a hyperlink from Firefox (needs to be recent firefox as there was a bug with copy/paste rich text)
4. Paste the link into the email compose window
5. Observe the link pastes as rich text (if not, you have an older version of Thunderbird 3 or Firefox 3 on Mac that did not support rich text copy/paste.
6. Try to undo by typing Ctrl-Z or choose undo from menu

observe nothing happens
expected: pasted text is removed
Actual Results:  
Undo does not occur.  The more recent action seems to block all undos

Expected Results:  
Choosing undo removes the most recent pasted text (and even further history operations are undone if present).

As noted above, have not tested on windows or linux.  I can do so if needed.

Also as noted above, this impacts Thunderbird Compose window as well as SeaMonkey composer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 261392
You need to log in before you can comment on or make changes to this bug.