If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

non-immediate DOM changes to filters don't work

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Robert Longson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 356632 [details]
testcase

This may be related to or even a duplicate of bug 463939

The filter does not repaint itself possibly because DoApplyRenderingChangeToTree in nsCSSFrameConstructor does nothing for SVG frames but even if that is fixed the repaint does nothing as the filter invalidation BBox is empty.
(Reporter)

Comment 1

9 years ago
Fixed by patch in bug 472135
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.