The default bug view has changed. See this FAQ.

mailto links don't work under Linux even after removing mimeTypes.rdf

UNCONFIRMED
Unassigned

Status

()

Firefox
File Handling
UNCONFIRMED
8 years ago
6 years ago

People

(Reporter: Vincent Lefevre, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Since I switched to Firefox 3 under Linux, the "mailto:" links no longer work. As I was using network.protocol-handler.app.mailto, I thought I was affected by bug 428658. But removing mimeTypes.rdf didn't change anything.

Reproducible: Sometimes

Steps to Reproduce:
1. Quit Firefox (if it was running).
2. Remove the mimeTypes.rdf file.
3. Start Firefox.
4. Click on a mailto link (I've tried the one on my home page, which contains only an e-mail address and is known to work with FF2 and also with FF3 under Mac OS X).
Actual Results:  
Nothing happens.

Expected Results:  
Something should happen (that could even be an error if the user needs to reconfigure something).

Preferences -> Applications -> mailto said "Always ask". It seems that after starting Firefox a second time (without removing mimeTypes.rdf), the preferences say "Use mutt-mailto (default)", which was my network.protocol-handler.app.mailto settings (that worked with FF2). If I manually set it back to "Always ask", then after clicking on a mailto link, I get a window that allows me to choose the application. But Firefox refuses to start mutt-mailto (when I click on OK, nothing happens and the window is not closed). I don't get any error, even on the console.
(Reporter)

Comment 1

8 years ago
If fact, when I click on "Choose" then chooses my mutt-mailto script, it works!
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

6 years ago
I can't test Firefox 3.6.12 since Mozilla doesn't provide versions for x86_64. But I could test Debian's Iceweasel 3.5.15 (this is the latest version) with a fresh profile, and network.protocol-handler.app.mailto is no longer listed in about:config (in fact, nothing starting with network.protocol-handler.app). This is in contradiction with:

  http://kb.mozillazine.org/Network.protocol-handler.app.%28protocol%29

If this page is obsolete, it should be updated.
Status: RESOLVED → UNCONFIRMED
Hardware: x86 → x86_64
Resolution: INCOMPLETE → ---
(Reporter)

Comment 5

6 years ago
Downgrading importance to normal since one can set the application via the preferences (however one needs to change that manually for every account, which is not very practical).
Severity: major → normal
(Reporter)

Comment 6

6 years ago
(In reply to comment #4)
> I can't test Firefox 3.6.12 since Mozilla doesn't provide versions for x86_64.
> But I could test Debian's Iceweasel 3.5.15 (this is the latest version) with a
> fresh profile, and network.protocol-handler.app.mailto is no longer listed in
> about:config (in fact, nothing starting with network.protocol-handler.app).

Even if I add it manually, it isn't taken into account. I have checked that both network.protocol-handler.expose-all and network.protocol-handler.external.mailto are set to true (they are by default) as required, according to:

  http://kb.mozillazine.org/Network.protocol-handler.app.%28protocol%29

Looking at this more closely, after the browser is started with a fresh profile, a mimeTypes.rdf file is automatically created with a line:

  <RDF:Description RDF:about="urn:scheme:handler:mailto" NC:useSystemDefault="true" NC:alwaysAsk="false">

So, removing mimeTypes.rdf is useless. But even if I quit the browser, remove such lines related to mailto (keeping the XML file valid), and restart, either the behavior does not change (the default mail application is started) or mailto links do not work at all.

Updated

6 years ago
Whiteboard: [CLOSEME 2010-11-15]
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.