Closed Bug 473431 Opened 11 years ago Closed 11 years ago

Latvia Holidays 2009-2014

Categories

(Calendar :: Website, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: murzzz, Assigned: murzzz)

Details

Attachments

(1 file, 1 obsolete file)

16.73 KB, text/plain
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird version 2.0.0.19 (20081209)

Attached Latvian Holidays calendar

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached file Latvia Holidays calendar (obsolete) —
This is Latvia Holidays calendar
Component: General → Website
OS: Windows XP → All
QA Contact: general → website
Hardware: x86 → All
Attachment #356800 - Attachment mime type: application/octet-stream → text/plain
dm,
thanks for your contribution. However, I compared it to the entries at http://en.wikipedia.org/wiki/Public_holidays_in_Latvia and that does not 
really match.

Could you please elaborate on why that is?

I see the following issues with your calendar file:
- Declaration of independence holiday is on the next Monday in case the day 
  is on a weekend. Your calendar always shows it on May 4, but this will be 
  incorrect in 2013 and 2014
- Proclamation of the Republic of Latvia holiday is on the next Monday in 
  case the day is on a weekend. Your calendar always shows it on November 18, 
  but this will be incorrect in 2012
- Your calendar misses the Good Friday (Lielā Piektdiena), Easter Sunday 
  (Lieldienas) and Easter Monday (2. Lieldienas) holidays

Could you please post an updated calendar file here. I would also appreciate it, if you could a few more years to the calendar file, so that it won't be outdated at the end of this year already.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hello Simon 'sipaq' Paquet.

The source I used is here: http://likumi.lv/doc.php?id=72608
Likumi.lv is the site where all Latvian state laws are published.
There are 2 types of holidays defined in that particular law: public holidays (they all are mentioned in wikipedia, right) and memorial days. I decided to include both types in one file.

18 of November and 4 of May.
Is it possible to shift event to the first working day if event's day is a weekend automatically? The other possibility I know is to do it manually, but that doesn't looks great to me.

Good Friday.
Since there is no way to make Lightning to calculate that automatically (or is it?) I have to create these events manually for every year I need, right?

Thanks for the hints!
Latvian holidays and memorial days from 2009 to 2014 including.
Attachment #356800 - Attachment is obsolete: true
File added to our website. Thanks for your contribution.
Assignee: nobody → murzzz
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Summary: Latvia Holidays calendar → Latvia Holidays 2009-2014
You need to log in before you can comment on or make changes to this bug.