Firefox hangs when a Java applet codebase is unreachable.

RESOLVED WONTFIX

Status

Plugins Graveyard
Java (Java Embedding Plugin)
--
critical
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: Nick Lowe, Assigned: smichaud)

Tracking

({hang, testcase})

unspecified
All
Mac OS X
hang, testcase
Bug Flags:
wanted1.9.2 ?

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090112 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090112 Shiretoko/3.1b3pre

When the codebase attribute of an <applet> is not avavilable, Firefox hangs:

<html>
<head>
<title>Applet Bug Test</title>
</head>
<body>
<applet code="sevenAMNewsTicker.class" codebase="http://www.nonexistantdomain.com/" />
</body>
</html>

Reproducible: Always

Steps to Reproduce:
1. Visit URL.
Actual Results:  
Firefox hangs.

Expected Results:  
Firefox should not hang.
(Reporter)

Comment 1

9 years ago
Created attachment 356880 [details]
Testcase demonstrating the issue.

Comment 2

9 years ago
Created attachment 356905 [details]
Activity monitor sample from submitted testcase

Comment 3

9 years ago
Bugzilla didn't pick up my comment; I'll try here.

Camino Version 2.0b2pre (1.9.0.6pre 2009011303) running under Mac OS X 10.4.11 on a PPC Mac hangs on the testcase, sort of.

If another program is open, and then quit normally -- either from the Dock or from the Finder -- Camino recovers.  I snagged the above Activity Monitor sample while Camino was not responding.
(Reporter)

Comment 4

9 years ago
Firefox does become responsive after a good minute of being hung.

The issues are:

1) The UI completely blocks until the timeout has occurred.
2) The timeout is probably too long.
(Assignee)

Comment 5

9 years ago
This is probably a bug in the JEP -- it (apparently) fails to distinguish between a codebase that doesn't exist and a codebase that's unreachable.

But this bug will be very seldom encountered, so I'm not going to give it a high priority.
Assignee: nobody → smichaud
Status: UNCONFIRMED → NEW
Component: General → Java Embedding Plugin
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → java.jep
(Reporter)

Updated

9 years ago
Hardware: x86_64 → All
(Reporter)

Updated

9 years ago
Keywords: hang, testcase
(Reporter)

Updated

9 years ago
Summary: Firefox hangs when an applet codebase is not available. → Firefox hangs when a Java applet codebase is unreachable.
Created attachment 375095 [details]
testcase2

I'm also seeing this hang on current Mac trunk build, when reloading this testcase, that only has a single <applet> tag.
I don't see it happening on Firefox3.0.10.
(Assignee)

Comment 7

9 years ago
Current Mac trunk (mozilla-central) builds don't have any Java support -- OJI and the Java Embedding Plugin have been removed.  The idea is that they'll be replaced by a new out-of-process NPAPI Java plugin that Apple and Sun are working on (it's a port of Sun's new out-of-process plugin).  See bug 485984.
(Reporter)

Comment 8

8 years ago
This still makes 3.6 hang.

Tested in:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
(Reporter)

Updated

8 years ago
Flags: wanted1.9.2?

Updated

8 years ago
Component: Java Embedding Plugin → Java (Java Embedding Plugin)
Product: Core → Plugins
(Reporter)

Comment 9

6 years ago
This still causes a complete lock up of the browser in 2012... Has it been forgotten about?
(In reply to comment #9)

What you're seeing is a different bug.  Or rather it's the same bug (sort of) in different code.

See bug 717986.

The JEP is no longer bundled with current versions of Firefox for the Mac (and hasn't been since FF 4).
(Following up comment #10)

Actually the bug you should see is bug 708461.

This bug still effects FF 3.6 (which still bundles the JEP).  But the 3.6 branch is (effectively) dead and I no longer have any time to work on the JEP, so this bug isn't going to get fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.