add space after comma in list values of search description to avoid early newlines

RESOLVED WORKSFORME

Status

()

P3
trivial
RESOLVED WORKSFORME
10 years ago
6 years ago

People

(Reporter: bigstijn, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Bugzilla 3.3.1

On buglist.cgi, in <ul class="search_description">, the list of values of a search item is comma-separated, but without spaces.  This is causing sometimes an early newline, because that list of values isn't split.

Eg.   <li>
    <strong>Severity:</strong>
    blocker,critical,major,normal,minor,trivial,enhancement
  </li>
should be written as
  <li>
    <strong>Severity:</strong>
    blocker, critical, major, normal, minor, trivial, enhancement
  </li>

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 356921 [details]
early newline after severity

Updated

10 years ago
Version: unspecified → 3.3.1

Comment 2

10 years ago
That value is literally what Search.pm is seeing, so that's what it prints out. I agree it would be nicer to display it with spaces, but it's unlikely to happen any time soon, unless there's some refactoring of Search.pm.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Not able to reproduce this issue against trunk.

Comment 4

6 years ago
I cannot reproduce this issue on any supported branch either.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.