Closed Bug 473536 Opened 11 years ago Closed 11 years ago

Tags textbox on editBookmarkPanel is too narrow for a large font

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows 2000
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.6a1

People

(Reporter: spitfire.kuden, Assigned: mak)

References

Details

(Keywords: regression, verified1.9.1)

Attachments

(2 files)

Attached image screenshot
- Windows 2000
- Windows Standard (extra large)
i was also thinking we could probably change min-width to em
Target Milestone: --- → Firefox 3.1
Attached patch patchSplinter Review
Dao, do you think moving to ems could be enough?
Attachment #357371 - Flags: review?(dao)
Attachment #357371 - Flags: review?(dao) → review+
Comment on attachment 357371 [details] [diff] [review]
patch

Using em is good for large fonts, but it won't help locales where "Separate tags with commas" is longer.
well, and italian is one of those, not sure if we can make so that the autocomplete field leads the size.
the strange thing is that i've tried to locally backout bug 413053 and the issue is still present...
And i see the same issue in the 12-01 nightly:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090112 Minefield/3.2a1pre
This does not contain my patch... i'll look for a better regression range
What exactly are you looking for? The fact that the emptytext can be too long isn't a regression.
exactly, the textbox (and the panel) was taking the width of the empty text previously, it's not doing it anymore
It never did, as far as I know.
that's strage because in my italian version of 3.0.5 the text that is "Separare più etichette con una virgola" is not cut at all
mh you're right, the fact the text is not cut happens due to menulist contents being larger too.
So this is good to go, thanks.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
http://hg.mozilla.org/mozilla-central/rev/a3abe1807f71
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 357371 [details] [diff] [review]
patch

requesting approval, needed to fix a regression with panel re-alignment
Attachment #357371 - Flags: approval1.9.1?
Reporter, can you please check if this fixes the issue for you on trunk? Thanks.
(In reply to comment #13)
> Reporter, can you please check if this fixes the issue for you on trunk?

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090120 Minefield/3.2a1pre

I confirmed fix of this bug. There is no problem.
Thanks Akihiro. It would be great if you could also check the fix after it has been fixed on 1.9.1 branch. Marking verified.
Status: RESOLVED → VERIFIED
Target Milestone: Firefox 3.1 → Firefox 3.2a1
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b489501f6929

pushed since this is a regression fix for an approved bug
Keywords: fixed1.9.1
Attachment #357371 - Flags: approval1.9.1?
Akihiro, could you please check with Shiretoko if it is fixed for you?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b4pre) Gecko/20090313 Shiretoko/3.1b4pre {Build ID: 20090313014819}
Desktop design: Windows Standard (extra large)

There is no problem. 
If this is not good, Localizer will do fix to this by using intl.css.
Thanks! Marking verified1.9.1 based on comment 18.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.