Mac: unable to save file from file picker via helper app Download dialog

VERIFIED DUPLICATE of bug 47248

Status

()

P3
critical
VERIFIED DUPLICATE of bug 47248
19 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: gagan)

Tracking

({platform-parity})

Trunk
PowerPC
Mac System 9.x
platform-parity
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
basically, if you're trying to download a file for which the helper app Download
dialog will recognize, you won't be able to save it using the Mac native file
picker. i'm guessing that, like bug 47248 (saving the file where you don't
choose where), this dependent on bug 47358 (involuntary downloading --period).

tested using branch commercial bits on Mac OS 9.0 [2000.08.02.04-m17]. to repro:

1. go to http://www.mozilla.org/
2. scroll down to the Nightly Build section.
3. select the Macintosh link that will cause the new helper app Download dialog
to appear.
4. once the Download dialog appears, wait for the progress meter to complete
(bug 47358).
5. select the Save to Disk radio button.
6. click OK --the native Mac file picker will appear.
7. specify a location other than the Desktop *OR* change the filename.
8. click OK.

result: no file is downloaded.

expected: the file should be download where the user specifies, and/or with name
specified.
(Reporter)

Comment 1

19 years ago
kw's...
Depends on: 47248, 47358
Keywords: dogfood, nsbeta2, nsbeta3, pp

Comment 2

19 years ago
i don't see where this is different from the bug you already filed: 47248: save
file dialog for the mac isn't working when it is brought up by the helper app

*** This bug has been marked as a duplicate of 47248 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

19 years ago
h'm, now that i think about it... (all these downloading issues are messy.)
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.