Intermittent crashtest timeouts 458637-1.html and 421715-1.html

REOPENED
Unassigned

Status

()

Core
DOM
REOPENED
9 years ago
9 years ago

People

(Reporter: roc, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-unittest/build/content/base/crashtests/458637-1.html | timed out waiting for onload to fire
REFTEST TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-unittest/build/content/canvas/crashtests/421715-1.html | timed out waiting for onload to fire

These have been occurring frequently on Windows trunk for the last week. They always occur together. This behaviour started on 1a4e256b6894 although 458637-1.html seems to have timed out at least once before then (although definitely a lot less often). Likewise, I only see one isolated timeout of 458637-1.html on the 1.9.1 branch, so that doesn't seem to be affected.
Test 421715-1.html happens to be the one after 458637-1.html. So maybe it's getting hammered by residual effects of 458637-1.html.
I tried running the test before and after the changes around 1a4e256b6894, and I got the same performance both times, so I can't see what might have changed there.

I'll land my fix in bug 473680 to make 458637-1.html more reasonable, and then we'll see if that fixes the random orange.
My fix seems to have stopped these tests from failing. I guess we'll leave it at that.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
I spoke too soon, there have been a lot of failures recently.

Boris, you fixed 458637, any ideas spring to mind?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Not off the top of my head.  :(
(In reply to comment #2)
> I'll land my fix in bug 473680

Duplicate of that bug !?
Depends on: 473680

Updated

9 years ago
Component: Content → DOM
QA Contact: content → general
You need to log in before you can comment on or make changes to this bug.