Closed Bug 473715 Opened 11 years ago Closed 11 years ago

LDAP fails to initialise in compose window

Categories

(MailNews Core :: Address Book, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: chrism, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/1.0.154.43 Safari/525.19
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090114 Shredder/3.0b2pre

When composing mail (subsequent to nightly update to 20090113) Shredder cannot access the LDAP server for address book records.  When I start to compose mail, the following message appears under the To: field:
<LDAP initialization problem>

Clicking on it reveals the following error:

Error code 0xc1f30001: Unknown error
Please contact your System Administrator.


Reproducible: Always

Steps to Reproduce:
1. Upgrade to Shredder nightly after 20090113
2. Use an LDAP Address Book
3. Start to type the To: address for an email.
Actual Results:  
<LDAP initialization failed> appears below the address box

Expected Results:  
Search results for the part-entered address shows.

Only started since 20090113 update.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 473594
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Assignee: nobody → bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3+
Keywords: regression
Target Milestone: --- → Thunderbird 3.0b2
Blocks: 419595
Product: Thunderbird → MailNews Core
QA Contact: address-book → addressbook
Version: unspecified → Trunk
Attached patch The fix (obsolete) — Splinter Review
The problem is that with the changes I did in bug 419595 we need to call init() on the nsILDAPURL. Given that we already have the full url, the simplest fix is to get the nsILDAPURL via the io service and we'll know everything is correct.
Attachment #357939 - Flags: superreview?(neil)
Attachment #357939 - Flags: review?(bienvenu)
Attachment #357939 - Flags: review?(bienvenu) → review+
Duplicate of this bug: 474726
Whiteboard: [patch in progress]
Attached patch The fix v2Splinter Review
Fixes SM LDAP autocomplete properly.
Attachment #357939 - Attachment is obsolete: true
Attachment #358163 - Flags: superreview?(neil)
Attachment #358163 - Flags: review+
Attachment #357939 - Flags: superreview?(neil)
Comment on attachment 358163 [details] [diff] [review]
The fix v2

>+            let url =
>+              sPrefs.getComplexValue(autocompleteDirectory +".uri",
>+                                     Components.interfaces.nsISupportsString)
>+                    .data;
I know you want to wrap to 80 chars but 4 lines is a bit excessive... I'd use
var url = sPrefs.getComplexValue(autocompleteDirectory + ".uri",
    Components.interfaces.nsISupportsString).data;
Attachment #358163 - Flags: superreview?(neil) → superreview+
Patch checked in: http://hg.mozilla.org/comm-central/rev/1df064913853

Fix will be in tomorrow's nightlies.
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [patch in progress]
You need to log in before you can comment on or make changes to this bug.