All users were logged out of Bugzilla on October 13th, 2018

D&D a bookmark or folder of the Bookmarks Toolbar on itself let it appear sunken

RESOLVED DUPLICATE of bug 225434

Status

()

RESOLVED DUPLICATE of bug 225434
10 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

3.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090114 Shiretoko/3.1b3pre Ubiquity/0.1.4 ID:20090114020333

If you have a bookmark or a folder on the Bookmarks Toolbar and you try to move it around, it will appear as sunken if you drop it on itself and hovering afterward.

Steps:
1. Create a folder or a bookmark on the Bookmarks Toolbar
2. Start dragging this bookmark or folder
3. Drop it onto itself
4. Hover over the bookmark or folder

With step 4 you will see that the bookmark/folder appears as sunken when you hover it. This behavior is resetted when you perform a click on it. Any further hovering shows the normal hover state (half sunken).

It also happens with Firefox 3.0.x on OS X.
(Reporter)

Comment 1

10 years ago
I see following exception:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.moveItem]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: file:///Volumes/Minefield/Minefield.app/Contents/MacOS/components/nsPlacesTransactionsService.js :: PMIT_doTransaction :: line 558"  data: no]
Duplicate of Bug 225434 ?
(Reporter)

Comment 3

10 years ago
Yes, should have been done a better search. Thanks Ria.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 225434
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.