reduce mozconfig cruft required to build wince

RESOLVED DUPLICATE of bug 458088

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 458088
9 years ago
2 months ago

People

(Reporter: dougt, Unassigned)

Tracking

Trunk
x86
Windows CE

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
This stuff should just be rolled into configure.in

ac_add_options --disable-javaxpcom
ac_add_options --disable-plugins
ac_add_options --disable-accessibility
ac_add_options --disable-printing
ac_add_options --disable-oji
ac_add_options --disable-vista-sdk-requirements
ac_add_options --disable-updater
ac_add_options --disable-installer
ac_add_options --disable-xpinstall
ac_add_options --enable-image-decoders="png gif jpeg"
ac_add_options --disable-dbm

CROSS_COMPILE=1
MIDL=/c/Program\ Files/Microsoft\ Visual\ Studio\ 9/VC/ce/bin/x86_arm/midl.exe

mk_add_options AR=@TOPSRCDIR@/build/wince/tools/bin/arm-wince-lib

ac_add_options --target=arm-wince
ac_add_options --enable-win32-target=WINCE
ac_add_options --enable-default-toolkit=cairo-windows

ac_add_options --with-wince-sdk="c:/program files/windows mobile 6 sdk/pocketpc"

# Disabling tests due to bug 454881
ac_add_options --disable-tests

#WINCE specific options

Updated

9 years ago
Flags: wanted-fennec1.0+
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458088

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.