If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

localhost => www.localhost.com

RESOLVED DUPLICATE of bug 150025

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 150025
9 years ago
9 years ago

People

(Reporter: fisharebest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Even when browser.fixup.alternate.enabled is set to true, it should never apply the fixup to "localhost".

Nobody *ever* typed "localhost" when they really wanted "www.localhost.com".

Reproducible: Always

Steps to Reproduce:
Fetch a "broken" local web application using the URL "http://localhost/myapp/index.php"


Actual Results:  
After the "broken" page errors, Firefox redirects to the URL "http://www.localhost.com/myapp/index.php".


Expected Results:  
Firefox should have given me a "page load error" for "localhost", not one for www.localhost.com

The "fixup" should not apply to "localhost".  This site should be treated as a special case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 150025
You need to log in before you can comment on or make changes to this bug.