Artifacts when opening/closing the folder dropdown of the edit bookmarks panel

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Core
Layout: View Rendering
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: whimboo, Assigned: dholbert)

Tracking

({regression})

Trunk
mozilla1.9.2a1
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 472769])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 357550 [details]
Artifacts

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090117 Minefield/3.2a1pre ID:20090117033728

There are artifacts left when opening and closing the folder list of the edit bookmarks panel. See the attached screenshot. This only happens on trunk. Shiretoko is ok for now.

Steps:
1. Press Ctrl+D to add a bookmark
2. Open and close the folder dropdown

Marco, could this have been regressed by any of your fixes lately?
(Reporter)

Comment 1

9 years ago
Should be a regression from bug 413053.
Blocks: 413053

Updated

9 years ago
Component: Places → GFX: Win32
Product: Firefox → Core
QA Contact: places → win32
i cannot reproduce on current trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090118 Minefield/3.2a1pre

since you said me you're testing under Fusion, could maybe be related.
Could you please confirm the regression range on bug 413053?
Keywords: regressionwindow-wanted
I've seen this as well without Fusion. I can't reproduce it right now with a build from yesterday.
(Reporter)

Comment 4

9 years ago
Marco, be happy. It's not your fault. I was able to narrow down the regression range. The regression starts between the following changesets:

http://hg.mozilla.org/mozilla-central/rev/670a3b50dfe0
http://hg.mozilla.org/mozilla-central/rev/28488df9e75e

Checkins:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=670a3b50dfe0&tochange=28488df9e75e

Could this somehow be a regression from bug 456219?
Keywords: regressionwindow-wanted
(Reporter)

Updated

9 years ago
No longer blocks: 413053
(Reporter)

Comment 5

9 years ago
(In reply to comment #3)
> I've seen this as well without Fusion. I can't reproduce it right now with a
> build from yesterday.

Dao, it's still visible with the latest trunk build.
Bug 456219 is very likely the cause because that's also what (most likely) caused bug 472769.

Updated

9 years ago
Blocks: 456219
Component: GFX: Win32 → Layout: View Rendering
Depends on: 472769
QA Contact: win32 → layout.view-rendering
(Assignee)

Updated

9 years ago
Duplicate of this bug: 474817
(Assignee)

Comment 8

9 years ago
I just fired off a try-server build with attachment 360124 [details] [diff] [review], the 
current fix for bug 472769.  Henrik, when that's done, would you mind testing that build to see if this bug is fixed in it?
  https://build.mozilla.org/tryserver-builds/?C=M;O=D
(thanks!)
(Reporter)

Comment 9

9 years ago
Something has been busted while building this tryserver build. There is no zip file available:

https://build.mozilla.org/tryserver-builds/2009-02-02_13:32-dholbert@mozilla.com-try-a798f8ddb6e/

Can you build it again? I'll run the test when it has been finished.
(Assignee)

Comment 10

9 years ago
Pushed to tryserver again last night, and that one apparently built correctly:
https://build.mozilla.org/tryserver-builds/2009-02-03_02:50-dholbert@mozilla.com-try-acc9dc6f892/
(Reporter)

Comment 11

9 years ago
Daniel, this build fixes the artifacts for sure. None of them are visible anymore.
(Assignee)

Comment 12

9 years ago
I've now landed the patch used in that tryserver build, which should fix both bug 472769 and this bug.

The changeset was http://hg.mozilla.org/mozilla-central/pushloghtml
Assignee: nobody → dholbert
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

9 years ago
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090207 Minefield/3.2a1pre ID:20090207033501
Status: RESOLVED → VERIFIED
Whiteboard: [fixed by bug 472769]
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.