If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Using the command modifier key while submitting a form should open the page in a new window/tab

VERIFIED DUPLICATE of bug 17754

Status

Camino Graveyard
General
--
enhancement
VERIFIED DUPLICATE of bug 17754
9 years ago
9 years ago

People

(Reporter: Yuan Qi, Unassigned)

Tracking

Details

(Whiteboard: DUPEME)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9.0.6pre) Gecko/2008121820 Camino/2.0b1 (like Firefox/3.0.6pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9.0.6pre) Gecko/2008121820 Camino/2.0b1 (like Firefox/3.0.6pre)

This behaviour is implemented in Safari and it's very useful for search sites but also useful in many other situations. Basically, if the user cmd-clicked a submit button, the form submission will be done in a new window/tab (depending the preference "Links opened with Cmd-Click"). If the form can be submitted by pressing the return button, Cmd-return will submit the form in a new window/tab.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Whiteboard: DUPEME

Comment 1

9 years ago
dupe of bug 17754 ?
Yep, that's the one I was thinking of.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 17754

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.