Closed Bug 474294 Opened 11 years ago Closed 11 years ago

Support aria-expanded on more roles

Categories

(Core :: Disability Access APIs, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.1b4

People

(Reporter: aaronlev, Assigned: davidb)

References

(Blocks 1 open bug)

Details

(Keywords: access, verified1.9.1)

Attachments

(1 file)

The spec now has an expanded list of roles that aria-expanded can be used on:
http://www.w3.org/WAI/PF/aria/#aria-expanded

It applies to almost everything, including landmarks, which currently aren't in the state map. The best thing for now is to just move aria-expanded to the universal state map in nsARIAMap.cpp.

At some point we're going to need to provide some constraints on the universal (global) states anyway, and at that point we can refactor the ARIA support a bit. (This relates to Henri's proposal that there are HTML elements which inherit ARIA roles).
Aaron, is this the idea? (Note: mochitests pass)
Attachment #357716 - Flags: review?(aaronleventhal)
Shall we move landmarks into the state map on this bug?
Attachment #357716 - Flags: review?(aaronleventhal) → review+
Comment on attachment 357716 [details] [diff] [review]
my 10 minute WIP - for discussion

Marco, if you are also happy with this feel free to push to trunk, thanks.
Attachment #357716 - Flags: review?(marco.zehe)
Attachment #357716 - Flags: review?(marco.zehe) → review+
(In reply to comment #2)
> Shall we move landmarks into the state map on this bug?

How do you mean? Make a state map for landmarks? Interesting idea.

Let's not do any major factoring until we know how we're dealing with ARIA in HTML:
Strong semantics that don't take ARIA
Weak semantics that can take ARIA, and may have a default role, or allow certain ARIA properties to be used which are not already global.
Pushed on David's behalf in changeset:
http://hg.mozilla.org/mozilla-central/rev/fae62c15f9a0
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 357716 [details] [diff] [review]
my 10 minute WIP - for discussion

ARIA 1.0 compliance.
Attachment #357716 - Flags: approval1.9.1?
A major AT vendor really wants this... I recommend this one for 1.9.1 as well.
Comment on attachment 357716 [details] [diff] [review]
my 10 minute WIP - for discussion

a191=beltzner
Attachment #357716 - Flags: approval1.9.1? → approval1.9.1+
Pushed to mozilla-1.9.1 on David's behalf in changeset:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4f61ba8f68f3
Keywords: fixed1.9.1
Target Milestone: --- → mozilla1.9.1b4
Verified fixed in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090422 Shiretoko/3.5b4pre (.NET CLR 3.5.30729)
Duplicate of this bug: 495406
You need to log in before you can comment on or make changes to this bug.