Closed Bug 474421 Opened 11 years ago Closed 11 years ago

Qt Widget no longer compiles in testplugin

Categories

(Core Graveyard :: Widget: Qt, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: johnflux, Assigned: johnflux)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: 

Qt Widget no longer compiles after bug fix for 448830.  The bug changed nsRect to nsIntRect in various functions, but did not update the qt widgets.


Reproducible: Always

Steps to Reproduce:
Try to compile with --enable-default-toolkit=cairo-qt 
Actual Results:  
Compile failure
Attached patch Fix for compiling qt widget (obsolete) — Splinter Review
This just follows the changes that were made to gtk2.

Both this and the previous patch need to be committed for Qt to compile again
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474187
Attachment #357788 - Attachment is obsolete: true
Hi, sorry, reopening for the first patch I supplied.  This patch is still required for fixing testplugin.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Qt Widget no longer compiles after bug fix for 448830 → Qt Widget no longer compiles in testplugin
Attachment #357787 - Flags: review+ → review?(joshmoz)
Comment on attachment 357787 [details] [diff] [review]
Minor fix for getting the tests compiling
[Checkin: Comment 6]

I don't know how qt plugins are supposed to draw, but even if this patch worked the reftests will fail. Its a start though.
Attachment #357787 - Flags: review?(joshmoz) → review+
Keywords: checkin-needed
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → johnflux
Comment on attachment 357787 [details] [diff] [review]
Minor fix for getting the tests compiling
[Checkin: Comment 6]


http://hg.mozilla.org/mozilla-central/rev/870843e43abe
Attachment #357787 - Attachment description: Minor fix for getting the tests compiling → Minor fix for getting the tests compiling [Checkin: Comment 6]
(In reply to comment #5)
> the reftests will fail. Its a start though.

R.Fixed for now: reopen or file a new bug, as needed.
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Depends on: 448830
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.