Save Webpage, complete doesn't save all files for Firefox default homepage

VERIFIED DUPLICATE of bug 115107

Status

VERIFIED DUPLICATE of bug 115107
10 years ago
3 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

1.9.0 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Created attachment 357791 [details]
Locally loaded web page with elements missing

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090117 Shiretoko/3.1b3pre Ubiquity/0.1.4 ID:20090117020415

Seen this while running a Smoketest for Firefox 3.0.6. Users who will use the default home page and do a "Save web page, complete" will not see the full page rendered after reloading it from the local disk. No additionally used files are getting downloaded. See the attachment for a screenshot and how it looks like.
I think this is an already-filed bug about HTML Complete not working as expected. Specifically, it doesn't get a bunch of references in CSS files. (see bug 126309)

The question I'd ask is... what happened previously? Is this new behavior?

If this is different than Firefox 2, it might be related to bug 454151.
Is the behavior exactly the same in 3.0, Henrik? How about 3.1 or 3.2 builds?

I notice that your build ID above is a 3.1 build ID, not the 3.0.6 one.
I filed this with 3.1. That's correct because it's still visible. I've retested it with Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 and noticed that it is even present in this build. So it's no regression from FF2.

I filed that as a new bug because I hadn't time to look into the details. But it looks like that this is probably caused by inline CSS?

Martijn, would it be something for you to analyze?
I think this is basically the same issue as bug 115107. It seems that backgrounds are not saved at all with Mozilla.
It has never been a regression in Fx, the bug has always been there. 

Henrik, the reason the Litmus test doesn't use the Fx startpage is to avoid reports of this long time known bug.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.