bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Browser closes when tab closed

VERIFIED DUPLICATE of bug 456382

Status

()

Firefox
Tabbed Browser
VERIFIED DUPLICATE of bug 456382
10 years ago
9 years ago

People

(Reporter: Tyler, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.0.3;MEGAUPLOAD 1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.0.3;MEGAUPLOAD 1.0

Mozilla Firefox crashes when middle-clicking the last open tab to close it.

Reproducible: Always

Steps to Reproduce:
1.Get one tab (total) open
2.middle click it
3.If it doesn't crash Firefox, then this is a theme problem
Actual Results:  
Firefox closed.  Not necessarily crashed, as I did not receive a recovery screen.

Expected Results:  
closed tab and reopened about:blank
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

I'm not able to reproduce this.

Comment 2

10 years ago
Maybe try in safe mode, with firefox 3.0.5. http://quality.mozilla.org/bug-writing-guidelines has more info and how to get a stacktrace.
Severity: normal → critical
Keywords: crash
Version: unspecified → 3.0 Branch

Comment 3

9 years ago
In Firefox/3.1b3 the error appears again - perhaps only the German version. In version 3.07 there is no error.

Updated

9 years ago
Duplicate of this bug: 486788

Comment 5

9 years ago
Please give more details ... I don't have this problem either.  What extensions are you using? Have you tried in safe mode?

Comment 6

9 years ago
Yes, I have tried it in safe mode, it is the same problem. I work with the German version and with Win 2000 SP4. - In the meentime I tried it with my laptop with Win XP SP2: Firefox crashes when closing the last tab. In both of the modes!

Have You tried it with Your version or with the German?

In 3.08 there is no error!

Comment 7

9 years ago
You also have some weirdness going on in your useragent.  Can you tell me what plugins you have?  Also try providing a crash report, see http://support.mozilla.com/en-US/kb/Firefox+crashes#Getting_information_about_your_crash

Comment 8

9 years ago
I work with Firefox_Setup_3.0.8dt.exe and Firefox_Setup_3.1_Beta_3.exe (7.573 kb) - German version.

The Firefox is Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Comment 10

9 years ago
I don't get the crash report, Firefox disappears without any notice. The Mozilla Crash Reporter doesn't appear.

1.
I use no addons. I work with the default theme. The plugins are
Adobe Acrobat 9.1.0.163
DivX Player Netscape Plugin 6.1.0.0
Divx Web Player 1.4.2.7
Microsoft DRM 9.0.0.2980 - DRM Netscape Network Object
Microsoft DRM 9.0.0.2980 - DRM Store Netscape Plugin
Mozilla Default Plug-in 1.0.0.15
RealJukebox NS Plugin 1.0.2.2146
RealPlayer Version Plugin 6.0.12.1069
RealPlayer(tm) G2 LiveConnect-Enabbled Plug-In
Shockwave Flash 9.0.124.0
Windows Media Player Plug-in Dynamic Link Libery 3.0.2.628

2. Tabs:
1. (yes) Statt mit neuem Fenster mit neuem Tab öffnen
2. (no)
3. (no)
4. (yes) Tab-Leiste immer anzeigen
5. (no)

3. Inhalt - I work without Java (but it doesn't matter - I tried it in the meantime).
The Languages are English + German

4. Anwendungen (programs)
- Acrobat
- Irfanview
- mailto
- Podcast
- Shockwave Flash Object
- Video-Podcast
- webcal
- Web-Feed
- Windows Media Player
- Winzip-File

5. Datenschutz (Safety of data)
all ist activated

6. Safety
no Master Password

7.
- Firefox isn't standard browser
- updates for Firefox + add-ons
- SSL 3.0 + TLS 1.0

With the advices in http://www.com-magazin.de/tipps/uebersicht/tipp-id/schliessen-button-fuer-firefox-tabs-aendern.html
I layed the close buttom to the right side like Mozilla.

Firefox 3.1b3 works with the same settings like 3.07 / 3.08 where no crash appears.

Comment 11

9 years ago
Now I know how the error works.

I told you that I layed the close-buttom to the right side like Mozilla (look at browser.tabs.closeButtons). Without this change the last tab of Firefox 3.1b3 doesn't show a close-buttom. But after the change the close-buttom is always shown AND it is working.

To stop this error there must be programmed in Firefox: if there is only 1 tab then the close-buttom must no work. For all options of browser.tabs.closeButtons: 0,1,2, 3.

Comment 12

9 years ago
The error appears too in the original version (without any changes) when you give "Strg"+W == closing tab.
OK, this is not a crash. If I understand it, you only have one tab open, and when you close it, the whole browser closes. his is expected behavior, but there is a bug on changing it. 
Bug 471437 and Bug 463827 are like this, not exact dupes though.
Severity: critical → normal
Keywords: crash
Summary: Tab crash when last tab → Browser closes when tab closed
Whiteboard: DUPEME

Comment 14

9 years ago
You say t"his is expected behavior, but there is a bug on changing it". 

But the behavior of version 3.07 or 3.08 are completely different! The last tab is always open and the browser does not close at any time. (This is the better way. For me, the "expected behavior" of 3.1b3 is a crash!)

Comment 15

9 years ago
Perhaps we speak about two different close buttoms: I mean this one which closes a tab and you that one which closes the whole window. The tab closing buttom must not close Firefox. (in Mozilla the tab is gone but Mozilla is still running)
OK, you mean that  close tab button, when pressed when only one tab is open, closes the whole browser. this is not a crash. However, in the latest 3.5, the tab close button is removed when only one tab is open. you can download it from ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-1.9.1/.

I think this can be WFM, as the tab close button is gone, and there is another bug (can't find atm), that is working on the last tab close behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 17

9 years ago
Your question was: how are you getting that close button on the far right?
What exactly is your issue? I am apparently misunderstanding it, so please state clearly for me.

I tried to work with your resolution of closing the tabs. But in the last years I worked with tabs in mozilla and Crazy Browser (that is a program based on IE 6) the close buttom is always on the right hand side. With the new handling I often opened new tabs instead of closing the used. Then I read of the change to the central close buttom. The autor began that he also had much problems with the new handling. I tried it and it worked, but not in 3.1b3. 

It is a good idea to open new tabs with the green cross at each tab instead of one on the left but with the two possibilities I can't work.

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
I would love to read the article, but it is in German. Maybe Matti can understand it?
I'm a little bit confused, the bug is about the the last Tab that if you try to close it (middle click, additional button), it closes the whole window which is unexpected and I agree that it's unexpected and bad but it seems that this is a wanted design decision and you can set browser.tabs.closeWindowWithLastTab to false if you don't like it. 
Then we have bug 486280 which should remove the last close button on the last tab if Firefox is set to always display at least one tab (by default).

The article describes http://kb.mozillazine.org/Browser.tabs.closeButtons which let you enable the old close Button on the right side like Firefox1.X or my current Seamonkey nightly.

Comment 21

9 years ago
I don't think that it is a wanted design decision. 

Look at the first article of this bug. There you will find the same error in version 3.0.3. In the meantime the error was corrected in 3.07 / 3.08. Now it appears in 3.1b3 / 3.5x. Perhaps you can take the corrections of 3.07 to 3.5x.
Created attachment 371992 [details]
Screenshot

For reference, this is a screenshot the reporter gave me.
>I don't think that it is a wanted design decision. 

This makes no logical sense . Why do you think they added a new hidden preference and set it per default to "no" ?

I used mxr.mozilla.org and this is a wanted decision from bug 392870 and the hidden pref was added with bug 455852.
Then we have bug 455990 and bug 456382, marking as dupe of bug 456382
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456382
This problem exists only in last version 3.0.8 !
In previous version 3.0.7 it isn't occur !

EVERYTIME when using multiple TABs... clicking the "X" to close one of all and
other still loading the FF 3.0.8 crash. :-( 

Please, correct this fatal error !

Thanks.
Morais
 Alexandre Morais de Mello: You don't see this bug, this bug is about a that Firefox closes if you close the only and last remaining tab.

Updated

9 years ago
Status: RESOLVED → VERIFIED

Comment 26

9 years ago
In the meantime I installed the add-ons adblockplus-1.0.1, autopager 0.4.2.2, customizegoogle-0.76.de, GooglePreview 3.19, Image Zoom 0.3.1, WOT 20090325 and Tab Mix Plus 0.3.7.3. I made some tests with all of them espacially Tab Mix Plus 0.3.7.3 before I uninstalled Tab Mix. The other add-ons are activated now:  the error is gone!!!
You need to log in before you can comment on or make changes to this bug.