No gradient in titlebar after hiding/collapsing main toolbar with the toolbar control

RESOLVED DUPLICATE of bug 461291

Status

()

Core
Widget: Cocoa
--
trivial
RESOLVED DUPLICATE of bug 461291
9 years ago
9 years ago

People

(Reporter: Zach Dennison, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

It's a very minor issue, but in Mac OS X 10.5 Leopard, when you click the roll up button (opposite side from the close/minimize/maximize buttons), the window doesn't roll up like most applications. Most applications roll up the bottom of the area to be hidden so that the title bar becomes a gradient. Firefox, however, just truncates the area to be hidden. It becomes very obvious when you have the tab bar showing. The bottom of the navigation bar normally blends seamlessly with the tabs, but when it's rolled up, it clashes.

Reproducible: Always

Steps to Reproduce:
1. Press the roll up button in the upper right hand corner of the window.
2. If you don't immediately notice, open a new tab, and it'll stand out.
3.
Think shell is better for this.
Component: Theme → Shell Integration
QA Contact: theme → shell.integration
Version: unspecified → 3.0 Branch
More likely a widget bug
Assignee: nobody → joshmoz
Component: Shell Integration → Widget: Cocoa
Product: Firefox → Core
QA Contact: shell.integration → cocoa
Version: 3.0 Branch → unspecified
(Reporter)

Comment 3

9 years ago
what do you mean by a widget bug? by the way, it happens in the beta version of Thunderbird too (I don't expect anyone from there to see this, just thought I'd share that knowledge).
Widget is just a component of the Core Thunderbird application. Can you try installing ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-trunk/ to get the latest Thunderbird to see if this happens still (probably does, just covering bases0.
Version: unspecified → Trunk
When the main toolbar is hidden/collapsed, the titlebar does not usually "match" the color of any secondary toolbar still visible (Finder, OmniWeb, Camino, Coda, Colloquy).  However, the titlebar does retain a dark gradient when the main toolbar is collapsed/hidden.

In XUL apps, however, hiding the toolbar leaves a (lighter grey) flat-color titlebar, almost the same color as a background window's tool/titlebar should be.  

Markus, do you have another bug on this?  It sounds familiar, but this bug still exists in 3.1b2.
Summary: Windows don't roll up correctly → No gradient in titlebar after hiding/collapsing main toolbar with the toolbar control
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461291
You need to log in before you can comment on or make changes to this bug.