File.ics from Sunbird 0.2 causes an error on import

RESOLVED DUPLICATE of bug 334657

Status

RESOLVED DUPLICATE of bug 334657
10 years ago
9 years ago

People

(Reporter: a.ramalhao, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: 0.9 I don't know exactly, but downloaded it today

If I import the Old calendar (ics)  from Sunbird 0.2 , that does not work.
Instead it shows the Following error:

Unable to read from file:K\MozillaCalendars\CalenadarDataFile1.ics
[Execption... "Component returned failure code: 0x8000ffff(NS_ERROR_UNEXPECTED)
[nsIScripableUnicodeConverter.convertFromByteArray]" nsresul: "0x8000ffff
(NS_ERROR_UNEXPECTED)" location: "JS frame ::
file:///C:/Programme/Mozilla%20Sunbird/components/calItemModule.js ->
file:///C:/Programme/Mozilla%20Sunbird/js/calIcsParser.js :: ip_parserFromStream :: line 185" data:
no]

How can I ever get this ICS File working?
I need the data of the file .


Reproducible: Always

Steps to Reproduce:
1.Import this special file.
2.
3.



it is a german localised System
(Reporter)

Comment 1

10 years ago
Created attachment 357944 [details]
This is the error message
(In reply to comment #0)
> Unable to read from file:K\MozillaCalendars\CalenadarDataFile1.ics
> [Execption... "Component returned failure code: 0x8000ffff(NS_ERROR_UNEXPECTED)
> [nsIScripableUnicodeConverter.convertFromByteArray]" nsresul: "0x8000ffff
> (NS_ERROR_UNEXPECTED)" location: "JS frame ::
> file:///C:/Programme/Mozilla%20Sunbird/components/calItemModule.js ->
> file:///C:/Programme/Mozilla%20Sunbird/js/calIcsParser.js ::
> ip_parserFromStream :: line 185" data:
> no]

The error message could indicate that the ics file is not UTF-8 encoded.
Probably an utf8 error, yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 334657
You need to log in before you can comment on or make changes to this bug.