Double-clicking on first letter of a word selects previous word

VERIFIED DUPLICATE of bug 16352

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 16352
18 years ago
17 years ago

People

(Reporter: Adam Lock, Assigned: anthonyd)

Tracking

({helpwanted})

Trunk
Future
x86
All
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Run Mozilla and point it at any page (www.mozilla.org will do). Find two words 
in the same paragraph and double-click on the first letter of the second word. 
Both the first and second word are selected.

e.g.

Hello World
      ^ Double click on the 'W'

Comment 1

18 years ago
Confirmed on Linux 2000080108 - Changing OS to all.
OS: Windows NT → All

Comment 2

18 years ago
->Editor
Assignee: trudelle → beppe
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay

Comment 3

18 years ago
reassigning to akk for now -- Akkana, were you working on this part of selection 
or should this go to Mike?
Assignee: beppe → akkana

Comment 4

18 years ago
That's me, since I have another bug on word selection.
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: --- → M18

Comment 5

18 years ago
Moving to M19 as per beppe@netscape.com.
Target Milestone: M18 → M19

Comment 6

18 years ago
moving this out to future, this may result in a rewrite of word selection
Keywords: helpwanted
Priority: P2 → P3
Target Milestone: M19 → Future

Comment 7

18 years ago
Anthony is taking over selection bugs.
Assignee: akkana → anthonyd
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
sometimes when i doubleclick in the URL textfield, the selection goes from the
beginning of the field to where the cursor is --rather than the entire URL field
contents. [annoyingly inconsistent] akkana mentioned that this and bug 16352 are
prolly the cause of that.

Comment 9

17 years ago
se: i think that's bug 16203, "double-click drag should do selection in "word-
by-word" mode".

isn't this bug a dup of bug 16352?

Comment 10

17 years ago
*** Bug 65856 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 16352 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

17 years ago
I don't mind you duping this bug, just as long as it's noted that this is a
genuine bug while bug 16352 is talking about improving selection heuristics.
You need to log in before you can comment on or make changes to this bug.