onbeforeunload fired twice when using Close Window menuitem or Accel+Shift+W

VERIFIED WORKSFORME

Status

()

Firefox
Menus
P2
normal
VERIFIED WORKSFORME
10 years ago
9 years ago

People

(Reporter: mconnor, Assigned: mconnor)

Tracking

3.5 Branch
Firefox 3.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
We call BrowserTryToCloseWindow twice in this particular case.  Not sure how long this has been the case, but doing this twice is a pretty annoying bug if there's a prompt.

attachment 339934 [details] works for seeing the problem.

Before the fix for bug 456447, you'll get two prompts, then the close all tabs prompt.  After, you'll get prompt, all tabs prompt, then prompt again.  oops.

WIll fix for 3.1 final, this would be really annoying, though on a hopefully-low-use codepath...
Flags: blocking-firefox3.1+
(Assignee)

Updated

10 years ago
Priority: -- → P2
Whiteboard: [needs patch]
(Assignee)

Comment 1

9 years ago
Created attachment 364189 [details] [diff] [review]
remove the onclose handler after we've already checked once

pretty simple...
Attachment #364189 - Flags: review?(gavin.sharp)
(Assignee)

Comment 2

9 years ago
I can't reproduce this now, maybe something else was broken.  Resolving WFM.  Will file a followup on another issue I found.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking-firefox3.1+
Resolution: --- → WORKSFORME
Attachment #364189 - Flags: review?(gavin.sharp)
Yeah, it's only fired once. Verified.
Status: RESOLVED → VERIFIED
Whiteboard: [needs patch]
Version: unspecified → 3.1 Branch
Target Milestone: Firefox 3.1 → Firefox 3.5
You need to log in before you can comment on or make changes to this bug.