Closed Bug 474812 Opened 11 years ago Closed 11 years ago

Xul apps exit quickly on first run on windows ce emulator

Categories

(Toolkit Graveyard :: XULRunner, defect)

ARM
Windows CE
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: blassey, Unassigned)

Details

Attachments

(1 file)

The second run works fine.
Attached file dump
we're crashing in filesys.exe

exception is:
(1ee44d02.1ee44cde): Access violation - code c0000005 (!!! second chance !!!)
022b437c 103096e5 ldr         r3, [r6, #0x10]


here's a stack trace:

0x22b437c
0x3ea63d8
coredll_3f4c000+0x1f970
nspr4_79620000+0x39d8c
nspr4_79620000+0x2d01c
nspr4_79620000+0x4bcc
xul_78180000+0xce2c70
xul_78180000+0xce54cc
xul_78180000+0xcec4f4
xul_78180000+0xcec8fc
xul_78180000+0xced9a4
xul_78180000+0x43591c
xul_78180000+0x43907c
xul_78180000+0x439a1c
xul_78180000+0x60290c
xul_78180000+0xc80a70
xul_78180000+0x27918
xul_78180000+0x6ff74
xul_78180000+0x59120
xul_78180000+0x294bc
After tracing through a bit, it seems the problem is that CreateFileW returns an invalid file handle.  The result of GetLastError is 0x5.

http://mxr.mozilla.org/mozilla-central/source/xpcom/io/nsLocalFileWin.cpp#403
Sorry, the file being opened is hiddenWindow.html.
ERROR_ACCESS_DENIED?

brad,
do you see anything on the console that may indicate running out of memory?
No, I suspect that hiddenWindow.html is being opened multiple times, and one of those times FILE_SHARE_READ isn't being specified.
I've been seeing this consistently on the emulator, but it appears to not be an issue on my device, I'm changing the summary and marking as won't fix.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Summary: Xul apps exit quickly on first run on windows ce → Xul apps exit quickly on first run on windows ce emulator
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.