Soft hyphen character does not render in XML

VERIFIED INVALID

Status

()

defect
P3
normal
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: christinehoff4, Assigned: nisheeth_mozilla)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

19 years ago
Using the following builds:

Win: 08_03_5 M17
Mac: 08_03_04 M17
Linux: 08_03_04 M17

Open the attached testcase. Soft hyphen character does not render using decimal 
or hexidecimal values.
Reporter

Comment 1

19 years ago
Assignee

Comment 2

19 years ago
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug,or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
Status: NEW → ASSIGNED
Assignee

Updated

19 years ago
Target Milestone: --- → Future

Comment 3

19 years ago
I thought ­ should be ignored unless there beginns a new line. (therefore
the name "soft hyphen").

The bug might be, that there is no hyphen on hyphenation; but there shouldn't be
one if there is none.

Suggest:
a) Mark as resolved, invalid
b) Mark as duplicate of bug 31304 (­ doesn't render), which is HTML
(You need to check first, whether this applys, I don't exactly know XML and
linebreaking in Mozilla)
c) Change the bug to a XML equivalent of (b)

The bug uses:
  = BO-BREAK SPACE (00A0)
­ = SOFT HYPHEN (00AD) = 173
­ = SOFT HYPHEN (00AD) = 173
I agree with Tobias, ­ should only be displayed when preceding a line-break.
See bug 9101. Resolving as INVALID.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Reporter

Comment 5

17 years ago
verified invalid
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.