Weekly Affiliates Top 250 totals don't update

RESOLVED FIXED in 3.0.3

Status

Websites Graveyard
spreadfirefox.com
--
major
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: ottodv, Assigned: abuchanan)

Tracking

unspecified
3.0.3

Details

(Whiteboard: affiliates, URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Fedora/3.0.5-1.fc9 Firefox/3.0.5
Build Identifier: 

The past 7 days total updates, but the all time total does not. My personal total has been stuck at 19,773 for a while now it seems to me.

Take a look at the top 10 today vs yesterday and it can't escape anyone that the all time totals have not been updated for anyone while the 7 totals have.

Today (jan 23, 2009):
1  	mozila  	11,168  58,487
2 	blueone 	9,999 	76
3 	ToastyX 	5,760 	19,942
4 	uretopia 	1,498 	4,883
5 	donmak 	 	1,491 	9,270
6 	hootie39 	1,301 	1,988
7 	marijnkampf 	1,214 	26
8 	SeaBass 	1,205 	12,258
9 	Usenet 	 	1,135 	275,894
10 	cucirca 	968 	5,222

Yesterday (jan 22, 2009):
1  	mozila  	11,528 	58,487
2 	blueone 	10,612 	76
3 	ToastyX 	5,873 	19,942
4 	donmak 	 	1,543 	9,270
5 	marijnkampf 	1,538 	26
6 	uretopia 	1,332 	4,883
7 	hootie39 	1,306 	1,988
8 	SeaBass 	1,269 	12,258
9 	Usenet 	 	1,169 	275,894
10 	dizi izle 	1,059 	7,583


Reproducible: Always

Steps to Reproduce:
1. http://www.spreadfirefox.com/affiliates/top_250
2. Check the cached google page for comparison: http://209.85.129.132/search?q=cache:http%3A//www.spreadfirefox.com/affiliates/top_250
Actual Results:  
All time totals remain the same day after day.

Expected Results:  
All time totals to increase each day.

I think this situation has been the case a long time already. When repairing it, it would be nice if the missing points from the entire period that this problem occurred were added to the totals.

Comment 1

9 years ago
Investigating ....
Assignee: nobody → paul

Comment 2

9 years ago
Thanks Otto,

From the information given it can be seen that all the "Past 7 Days" totals have gone down between successive days with the grand "Total" remaining fixed this then would seem to imply that there were no affiliate referrals collected on the 23rd January.

@Alex
Would you reassign this bug to someone who will be able to investigate if there was a problem with the running of the parsing script

Paul
(Reporter)

Comment 3

9 years ago
I don't think that there were no affiliate referrals collected for 1 or several days.

Take today's totals (Jan 29th, see below), and you'll see that the all time totals are still identical to the totals on Jan 22nd, a full 7 days later. If data hadn't been collected the 7 day totals would by now be zero for all affiliates. But instead the 7 days total is close to what it was 7 and 6 days ago, yet different (some higher and some lower).

This suggests to me that the referrals have been collected (the 7 day totals changes each day), but the collected referrals are not currently added to the all time total.

1  	mozila  	10,540  58,487
2 	blueone 	9,437 	76 
3 	ToastyX 	5,352 	19,942 
4 	dizi izle 	1,680 	7,583 
5 	marijnkampf 	1,513 	26
6 	uretopia 	1,497 	4,883
7 	SeaBass 	1,302 	12,258
8 	donmak 		1,262 	9,270
9 	Usenet 		1,139 	275,894
10 	cucirca 	1,114 	5,222

Updated

9 years ago
Assignee: paul → buchanae

Comment 4

9 years ago
@Alex

Do you want me to take a look into this ?

Updated

9 years ago
Severity: normal → blocker
Target Milestone: --- → 3.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Paul: I'd say Alex's answer was a yes.

I'll take a look at it this week.
Assignee: buchanae → paul.craciunoiu

Comment 6

9 years ago
Thanks Paul C :-)

Let me know if you need any help with anything.

Comment 7

9 years ago
@Paul C

It would be great if we could get get our affiliate program built on top of our affiliate module on D.O.  .The D6 version has been working without any problems on spreadthunderbird.com since October.

http://drupal.org/project/affiliates
https://wiki.mozilla.org/Spreadfirefox_migration_to_D6#Work_that_needs_to_be_done_after_offline_migration

It will brilliant to see the affiliate program working again :-)

Best, Paul

Comment 8

9 years ago
Paul C:  Are you working on this?  Or should I reassign to Buchanan?
OS: Linux → All
(Assignee)

Comment 9

9 years ago
I think Paul C is pretty busy with SUMO.  Anyway, I've already fixed this locally.
Assignee: paul.craciunoiu → buchanae
(Assignee)

Comment 10

9 years ago
Mary: There is no part of the new design that links to the top 250 page.  Do you have a suggestion for where we could link to it from?  

One option would be to change the destination of "Learn more" link on the Top Fox Spot from the affiliates homepage to be the top 250.

Comment 11

9 years ago
Rolo - do you want to link to the Top 250 off of the main page?

Comment 12

9 years ago
Hey again:  Could Neil add a link next to learn more for "View top 250"?

Thanks!
(Assignee)

Comment 13

9 years ago
I can do that

Comment 14

9 years ago
That would make me very happy and good catch!
Whiteboard: affiliates
(Assignee)

Comment 15

9 years ago
I added the top 250 link, and corresponding page.  It's viewable on stage @ 

https://spreadfirefox.authstage.mozilla.com/affiliates/top_250
(Assignee)

Comment 16

9 years ago
I've added the top 250 page (comment #15) and I've refactored the page slightly (no past 7 days total, usernames link to profiles) because the old page was broken in those areas.

The totals look to be updating on stage now.  I'll be adding in some code to help ensure that the traffic that goes into the logs, comes out as points.  QA, maybe we can work closely on this one, because it's important that affiliates points count correctly, but the setup is unique and hard to test.

I'm closing this because there are no tasks left to complete here (afaik) except testing and verification
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

9 years ago
graphicsguru pointed out that the list only goes to 122.  This is because the test script hasn't generated points for 250 different affiliates yet, so it doesn't mean it's broken.

I'll see if I can tweak the test log generator to get more affiliates.
(Reporter)

Comment 18

9 years ago
The past 7 day total is useful for affiliates. You can see if you are improving or not. The all time total doesn't give you a good feel for that.
(Assignee)

Comment 19

9 years ago
(In reply to comment #18)
> The past 7 day total is useful for affiliates. You can see if you are improving
> or not. The all time total doesn't give you a good feel for that.

Otto, I agree, but I think the Top 250 list should show only total points, because that's how it advertises itself, as the top 250 affiliates overall by total points.

I think that we're planning to implement some more detailed, per-user stats such as 7 day total in the near future.  I've created bug 486209 to keep in the table.
(Reporter)

Comment 20

9 years ago
Yes and no. I can see your point, that it makes sense to post this metric on the user profile. But....

The term "Top 250" does not imply "Of All Time", it's currently implemented (on the live SFx) as the "Top 250 Over The Past 7 Days".

It's a major change to go from "Over The Past 7 Days" to "Of All Time".

I'd imagine that the top 250 of all time, will be rather boring, with much less change day to day or week to week. Also why would someone with a high overall total who is no longer actively promoting Firefox stay on that list?

Although an all time view might have a place, I am not so sure that it should replace the top 250 over the past week as we know it now.
Totally agree with Otto.  Top 250 for the Week makes the most sense to me.

Comment 22

9 years ago
Laura:  What language would you want for block itself and the top 250 page?

https://spreadfirefox.authstage.mozilla.com/affiliates/top_250

https://spreadfirefox.authstage.mozilla.com/affiliates/top_250

Thanks!
I'm not really sure what you're asking for...

I'd like the title of the block to say "This Week's Top 250 Affiliates" and I'd want everything in english...

Is that what you're asking for?
(Assignee)

Comment 24

9 years ago
My bad, I was thinking top 250 meant "Of all time"

I'll change the top 250 to be more inline with what's on production.

Laura,  could you write a brief explanation re: the top 250 is sorted by the total points over the past 7 days?  We could put it above the list, or in the right sidebar.

I still think the "Top 250" link from the bottom of the Top Fox Spot block is slightly misleading, but I think the brief explanation will do for now.  Anyway, I suspect a more flexible affiliates list is in the near future (e.g. add more stats, make each column sortable)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 25

9 years ago
I forgot to mention, one difference from stage <> prod that I think we should keep is that user names are now linked to the user's SFx profile, instead of linking to their website.  This is important because we link user names to profiles all over the site, and we should be consistent.

I've left out the website link for now, as I think the user profile page is the proper home for that information.  If I'm missing an important reason to have that link on the top 250, please bring it up.
(Reporter)

Comment 26

9 years ago
Alex,

I guess there was a reason for the website links, probably in that it was a way to reward sites that promote Firefox with some traffic. It was also an easy way to check if a site really carried Firefox banners. I suppose the latter can also be done by going through a member's profile page.

What's not clear to me now is: are we going to have two columns again? (the 7 day and all time column) or is it just going to be the 7 day column now?

Comment 27

9 years ago
Otto makes a good point here about linking to the website -- it was a way to reward/showcase high performing affiliates and drive traffic back to their websites as recognition for helping to spread firefox.  It may be that there are other ways to do this (top foxes for example), but we should definitely consider how we as a community can help promote affiliates just as they help promote Firefox.
(Assignee)

Comment 28

9 years ago
So, should I add back the home page link too?  Since we've set a precedent for having it there?  What I don't want to do is link it from their user name, but I could easily add a "website" link

Should I add both columns, 7 day total, and total points?
(Reporter)

Comment 29

9 years ago
>Should I add both columns, 7 day total, and total points?

In my opinion, yes.

> What I don't want to do is link it from their user name,
> but I could easily add a "website" link

Agreed, it makes more sense to link the username to the SFx profile, which is more consistent with how it's done on other SFx pages, and have a separate website link.
Definitely Agree!  I think we should call it "Top 250 Affiliates" and the description could be

"Thank you to these Top Affiliates for helping to Spread Firefox!  If you want to learn more about the Affiliates program, check out our home page!" Link to http://www.spreadfirefox.com/affiliates/homepage

Comment 31

9 years ago
All good suggestions.  +1 for making the username link to the profile and a "website" link to their website.
(Assignee)

Comment 32

9 years ago
If the top 250 is based on a weekly sum, then I would think top 5 is the same.  What is top movers?  Currently, top movers is also based on a weekly sum.
(Assignee)

Comment 33

9 years ago
(In reply to comment #32)
> If the top 250 is based on a weekly sum, then I would think top 5 is the same. 
> What is top movers?  Currently, top movers is also based on a weekly sum.

We could call it top 250 movers, that would make the distinction clear.
(Assignee)

Comment 34

9 years ago
r24059 does everything up to comment #31
(Reporter)

Comment 35

9 years ago
The new top 250 is looking good.

Movers is an entirely different concept, it's a list of affiliates that have moved up the most relative to where they were 7 days ago.

Example:
Say my 7 day total is 100 and last week it was 25, then I've moved up by 75 points.

So naming the current top 250 "movers" is wrong. Though it might be an idea to also have a separate top250 movers list.

Finally, I think a list with the word "website" appearing 250 times on it will be rather ugly. Two possibilites come to mind: 1. a "website" icon, 2. the website's domain name (ex. http://www.accessfirefox.org/index.html would become "accessfirefox.org"). Alternatively, affiliates could be allowed set their own website's title.
(Assignee)

Comment 36

9 years ago
(In reply to comment #35)

> Example:
> Say my 7 day total is 100 and last week it was 25, then I've moved up by 75
> points.
> 

Ah, I see.  Thanks for helping understand these stats Otto.

> Finally, I think a list with the word "website" appearing 250 times on it will
> be rather ugly. Two possibilites come to mind: 1. a "website" icon, 2. the
> website's domain name (ex. http://www.accessfirefox.org/index.html would become
> "accessfirefox.org"). Alternatively, affiliates could be allowed set their own
> website's title.

do you have an icon in mind?  

I'm going to switch the Top Movers in the Top Fox Spot block to pull from that stat Otto explained in comment #35 and I think that will complete this bug.

I've filed bug 486523 for tracking a simple way to explain these stats.

Comment 37

9 years ago
Hey Alex:  I am confused by the "total" stat as it is the same as the past 7 days stat.  Is that because we started tracking it again this week?  If so, is there anyway to recupe affiliates' totals?
Akex:  I think the icon is a good idea, but not necessary for launch.  Let's go with "website" for the time being.  Also, I really think we need to recoup the totals--if not, I think we might have a huge contingent of pissed of people, and I'd rather not deal with that if possible. The definition bug has also been resolved.
(Reporter)

Comment 39

9 years ago
I would assume that the version on authstage is just a test. Most of the affiliates aren't on the list.

When moving to production, please also take care of the following issue: The totals also need to include the points collected since the system broke (some 6 months ago).

For me personally I expect that I gained some 8000 points over the last 6 months and yes I would be a bit disappointed if they weren't added. My commitment to Firefox is stronger than that, but I would assume a number of other people might not be so forgiving.

Comment 40

9 years ago
I agree with Otto. We really need to have the affiliate program working again with the relaunch.

https://wiki.mozilla.org/Spreadfirefox_affiliates#Some_thoughts_by_Paul_Booker

Best, Paul
(Assignee)

Comment 41

9 years ago
All information on stage is not guaranteed to be the same as production.  Production and stage are not synced currently, so disparities exist.

We haven't discussed recouping lost points for the past 6 months yet.  In the existing production system, only data for the past 30 days worth of affiliates referrals.  Recalculating points for the past 6 months would take a lot of work that we're not currently prepared to do.

I wish this had been brought up sooner than 1-2 days before the SFx v3 launch, but oh well.  I agree it's important to relaunch Affiliates fully and correctly, which means making sure users are OK with their point totals.  Currently I'm not 100% confident that everyone will be OK with their point totals.

So, I'm not sure what to do here yet.  I think we should probably meet today and figure this out.

Comment 42

9 years ago
"We haven't discussed recouping lost points for the past 6 months yet."

If this can't be done by parsing the apache logs then we will need to tell the community but we will need to choose our words carefully

"Recalculating points for the past 6 months would take a lot of work
that we're not currently prepared to do."

Hope that helps
Paul
(Reporter)

Comment 43

9 years ago
1. The Problem

"We haven't discussed recouping lost points for the past 6 months yet. [...] I wish this had been brought up sooner than 1-2 days before the SFx v3 launch,
but oh well.

Actually it was mentioned in the opening post of this problem, by none other than myself on January 23rd:

"When repairing it, it would be nice if the missing points from the entire period that this problem occurred were added to the totals."

2. Possible Solution

"Recalculating points for the past 6 months would take a lot of work
that we're not currently prepared to do."

There are of course several other options open to us, one which I would suggest (let me know if this is possible):

- Calculate the points over 4, 5 or 6 weeks evenly spread out over the missing period from the logs.
- Calculate an average and extrapolate what the point totals would have been over the missing period with that average.

I don't think this should be a show-stopper in any way, a correction could be done after SFx 3 has gone live, but I think to avoid some seriously unhappy affiliates it should be announced that a correction will be made.

Comment 44

9 years ago
I would say as an affiliate i would be happy if i was told directly that it would not be possible to recoup all the affiliate points accurately (we don't need to go into the details) but that a best effort would be made to capture these by extrapolating from accurate data that we have (again we don't need to go into the details))
Let's discuss this today.  Right now, I think the best option is to do what Paul suggests until after launch. Then we can see if we can look into the totals again and get more accurate numbers.
So, just discussed this with Alex live--
The best solution, considering the time we have left and the amount of effort its going to take to get the log information back, is to leave the totals as they are and to post on the Affiliates home page a message telling Affiliates that we're working on the problem. I just feel that if we are going to fix it, we should do it properly and in one go.  Two more weeks of weird stats, especially if we explain why, should still be tolerable.  I will draft a message for today to put on the home page.

Comment 47

9 years ago
Another idea might be to launch Spreadfirefox v3 without the broken affiliates program and instead for site users promote a relaunch of the affiliate program as "Coming soon!" on the new spreadfirefox site  and just have the affiliate program visible for site developers etc.

Personally i don't think its good idea to launch spreadfirefox (which is totally awesome and a real credit to Mary et al) with an affiliate program that is not 100% working as users would expect as it will be a stain on the whole relaunch (which should really be awesome).

Best, Paul

Comment 48

9 years ago
I'll defer to Laura here, but Paul brings up a good point.  To message to users/members yet again that the program is still broken may not be the best message for the general sfx launch.  If it's not a lot of work to hide areas of the affiliates program on the site temporarily and add "coming soon" messaging, it's something to consider.

Comment 49

9 years ago
Hey guys:  How about we roll with weekly totals so there is something to show traction?

Laura, Rolo & Buchanan - Can we meet now?

Thanks!

Comment 50

9 years ago
Ok - here is what we came up with as an action plan so we don't gate on this nor leave it out (which will be noticed since I've communicated about this):

- Focus on the fact that we have weekly totals working (yay!)
- Remove "Total" column from Top 250 page
- Add a blurb for Top 250 page explaining that we're working on historical totals (Laura working on this) and that is a priority (and will be gosh darn it!)
- Remove affiliate totals from profile page with plan to reinstate
- File bug to recover cumulative totals + additional metrics including button clicks, button type & downloads by day. (Laura to do this)

Thanks!
Top 250 Affiliates Page Blurb:

Top Text should remain the same (eg
"Thank you to these Top Affiliates for helping to Spread Firefox! If you want to learn more about the Affiliates program, check out our home page!)

Blurb should say
"Metrics coming soon: historical totals for all Affiliates, including button clicks, button types and downloads."
(Reporter)

Comment 52

9 years ago
I like Mary's suggestion, show the weekly totals, as they are correct. With the all time totals to be added once the data has been recovered. It's much better to show something that is working than to show nothing at all.

Besides the weekly total is the total that is used to sort the top250 anyway.

Comment 53

9 years ago
Good -- we'll keep driving on this to get this squared away :)

Comment 54

9 years ago
My counter is still on 0 points for several weeks now.
can some explain please what is wrong or how I get it to work ?

Comment 55

9 years ago
We will probably want to have the 'Website' link open up in a new window (as we do with our flickr module) so that we don't allow our users to navigate away from the site.
(Assignee)

Comment 56

9 years ago
r24229, fix top 250 page per comment #50

(In reply to comment #55)
> We will probably want to have the 'Website' link open up in a new window (as we
> do with our flickr module) so that we don't allow our users to navigate away
> from the site.

Done.
(Assignee)

Comment 57

9 years ago
Looking over this bug, I think all the changes have been made.  What's left is to test this in conjunction with bug 477638 to make sure that points are being counted/tallied correctly.  

QA and I will do that today sometime, and once we've verified that part, I'll mark this fixed.

Comment 58

9 years ago
Hey there:  Actually quick change to the blurb:

"Coming soon: Historical totals for all Affiliates."

We don't want to promise stuff at this point :)

Comment 59

9 years ago
Hi again:  I wanted to close the loop on this.  We're still having trouble tracking points.  We're taking the time to figure this out, as well as the historical data.  WebDev will be giving us an estimate of how long this will take to fix on Tuesday of next week.  Thanks!
(Assignee)

Comment 60

9 years ago
aravind just pushed out the affiliates points backfill and script updates.  Points should update tonight, sometime around 3am, so look for updated points in the morning.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 61

9 years ago
Reopening this bug as the totals are still not updated. In fact they have disappeared completely.

Removing the totals is not the same as solving the problem.

See also: Bug 493257
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 62

9 years ago
Indeed, everything is gone. I am an affiliate since 11 weeks with a lot of FF-downloads but not one single download has been countered.
(Assignee)

Comment 63

9 years ago
resetting severity for post-3.0 launch
Severity: blocker → major
(Assignee)

Comment 64

9 years ago
I've updated the Top 250 listing to include total points. 

r30529 checks this into stage.
https://spreadfirefox.authstage.mozilla.com/affiliates/top_250

(Unfortunately, the stage data is very out of date, and doesn't include good data for testing affiliates.  You can see the column header on the top 250 page on stage.  I'm working on filling in some test data) 

It looks to me like that's all that's needed to close this bug.  Otto, is that correct?
Hardware: x86 → All
Target Milestone: 3.0 → 3.0.3
(Reporter)

Comment 65

9 years ago
Hi Alex,

I don't actually see anything on stage except the column names, but they look ok to me.

We will have to see that it actually updates every day once live (which was the original bug). But I guess it will...
(Assignee)

Comment 66

9 years ago
This is in production, I forgot to close this bug.

http://www.spreadfirefox.com/affiliates/top_250
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.