bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

mail filter relationships "in/not in my address book" not usable for To:, CC: fields

RESOLVED DUPLICATE of bug 187768

Status

SeaMonkey
MailNews: General
RESOLVED DUPLICATE of bug 187768
10 years ago
10 years ago

People

(Reporter: Daniel B., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18) Gecko/20081031 SeaMonkey/1.1.13

In e-mail filters, the "is in my address book" and "isn't in my address book" 
relationships are arbitrarily limited to being used with the From: header 
field.  In particular, they can't be selected for use with the To: and CC: 
mail header fields.  They should be usable with the To: and CC: fields too.

(Yes, the in-address-book relationships _are_ useful with the To: and CC: 
fields.  Consider trying to differentiate spam from non-spam.  Mail addressed
to addresses you know is less likely to be spam than mail to unknown addresses.

Unfortunately, Seamonkey currently only lets you filter by whether the message
is _from_ an address you know, not letting you also filter by whether the
message it _to_ an address you know.)


Reproducible: Always

Steps to Reproduce:
1. Open a mail filter.
2. Set the field to "From".
3. Notice that the relationship list includes "is in my address book"
4. Change the field to "To", "Cc", or "To or Cc".
5. Notice that the relationship list no longer includes "is in my address book"

Actual Results:  
See steps.

Expected Results:  
In step 5, the address book options should still be available.
(Reporter)

Updated

10 years ago
Component: MailNews: Backend → MailNews: General
OS: Other → All
This is already possible in SeaMonkey 2.0 Alpha 2 -> DUPE
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187768
You need to log in before you can comment on or make changes to this bug.