Opening Unsorted Bookmarks traverses bookmark folder hierarchy

RESOLVED DUPLICATE of bug 475273

Status

()

RESOLVED DUPLICATE of bug 475273
10 years ago
9 years ago

People

(Reporter: luke.iliffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090125 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090125 Shiretoko/3.1b3pre

From the library/places organiser double clicking unsorted bookmarks in the right details pane causes the ever folder in All Bookmarks to be opened and closed.

Reproducible: Always

Steps to Reproduce:
1. New profile, open library form Bookmarks | Organize Bookmarks...
2. Double click unsorted bookmarks in the right hand details pane.
3.
Actual Results:  
In the left pane every folder under all bookmarks is opened and then closed again before finally finishing with unsorted bookmarks.

Expected Results:  
No opening and closing of folders in the left pane

It is easier to see if you create additional bookmark folders. This also happens on the 3.2a1pre trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475273
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.