Leak nsGenericElement with video (quitting while video is loading?)

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {mlk, testcase})

Trunk
x86
Mac OS X
mlk, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 358789 [details]
testcase

Steps to reproduce:
1. Load the testcase
2. Quickly quit (Cmd+Q)

Result: nsGenericElement and lots of other objects leak (as reported by trace-refcnt)

Probably not a major user-facing leak, since it only happens if you quit at the right time, but gets in the way of leak testing.
QA Contact: general → video.audio
(Reporter)

Comment 1

8 years ago
Dup of bug 503989?  This one only leaked an nsGenericElement, though.
Depends on: 503989
(Reporter)

Comment 2

8 years ago
No longer leaks on trunk.  Probably fixed by the patch in bug 503989.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.