Last Comment Bug 475316 - Firefox should detect if videos can't be played with the correct speed and take appropriate measures
: Firefox should detect if videos can't be played with the correct speed and ta...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Maire Reavy [:mreavy]
Mentors:
http://www.double.co.nz/video_test/te...
Depends on:
Blocks: 476397
  Show dependency treegraph
 
Reported: 2009-01-26 02:20 PST by Ria Klaassen (not reading all bugmail)
Modified: 2010-09-16 14:34 PDT (History)
5 users (show)
roc: blocking1.9.1-
roc: wanted1.9.1-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ria Klaassen (not reading all bugmail) 2009-01-26 02:20:45 PST
If I try to play the movie in the URL it goes in slow motion (less than 20% of the intended speed) and the sound is horrific.
The user can experience this as a failure of the browser. 
I suggest that the browser should detect if the movie can't run correctly, and do an attempt to resize the movie.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2009-01-27 15:17:07 PST
I don't really think there's much we can do. The problem won't be helped by resizing the movie.
Comment 2 James May [:fowl] 2009-11-23 05:53:17 PST
Firefox should at least warn you if it's going to try to do something that's going to lag out your computer, and give the option to tell it never to do it in future.

Is there somewhere is the <video> spec that allows a website to feature detect a browser's ability to play a specific video?
Comment 3 cajbir (:cajbir) 2010-07-21 21:39:09 PDT
There's nothing in the spec to allow a website to feature detect if a browser is having problems playing a video for performance or bandwidth reasons. See bug 580531 for pointers to some discussion on the WHATWG list about this and a patch to expose framerate to JavaScript.
Comment 4 Chris Pearce (:cpearce) 2010-09-16 14:34:18 PDT
We now skip the decode up to the next keyframe if the decode isn't keeping up with the playback, and we skip drawing frames if we're falling behind.

Note You need to log in before you can comment on or make changes to this bug.