Unify wording: "reminder" instead of "alarm"

RESOLVED FIXED in 1.1

Status

defect
--
trivial
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: mozilla, Assigned: Fallen)

Tracking

unspecified

Details

(Whiteboard: [has l10n impact], )

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090126 Calendar/1.0pre

In current builds we sometimes speak of "reminders" but also of "alarms" where probably the same is meant. This should be unified, especially in the preferences dialog.
I guess "alarm" is outdated? There are leftovers in calendar.dtd, preferences.dtd and alarms.dtd.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar1.0+
Whiteboard: [not needed beta][has l10n impact]
Posted patch Fix - v1Splinter Review
This patch changes the strings to "reminder". I haven't changed the entity names since this can be seen as a minor correction in the en-US localization and shouldn't require the localizers to change things. I'm not sure thats the correct way to do it, but we'll see.

This bug is for 1.0b6, so no rush for review.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #546392 - Flags: review?(matthew.mecca)
Flags: blocking-calendar1.0+
Whiteboard: [not needed beta][has l10n impact] → [has l10n impact][needs review]
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> Created attachment 546392 [details] [diff] [review]
> Fix - v1
> 
> This patch changes the strings to "reminder". I haven't changed the entity
> names since this can be seen as a minor correction in the en-US localization
> and shouldn't require the localizers to change things. I'm not sure thats
> the correct way to do it, but we'll see.

I wonder if any other localizations have a similar issue.


It looks like with the rapid release schedule, Thunderbird is only taking string changes on trunk to provide time for localization - are we planning to do the same?
Comment on attachment 546392 [details] [diff] [review]
Fix - v1

r=mmecca
Attachment #546392 - Flags: review?(matthew.mecca) → review+
Whiteboard: [has l10n impact][needs review] → [has l10n impact]
I'd go with the suggestion in comment 2, i.e. checkin l10n changes only to comm-central.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/edfbcb8dc14e>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
You need to log in before you can comment on or make changes to this bug.