Last Comment Bug 475383 - load plugins from $profile/plugins
: load plugins from $profile/plugins
Status: VERIFIED FIXED
: verified1.9.1
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks: 421611 491910 496534
  Show dependency treegraph
 
Reported: 2009-01-26 11:30 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2009-07-30 11:51 PDT (History)
13 users (show)
ted: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
.2-fixed


Attachments
append $profile/plugins to NS_APP_PLUGINS_DIR_LIST (946 bytes, patch)
2009-01-26 11:30 PST, Ted Mielczarek [:ted.mielczarek]
benjamin: review+
Details | Diff | Splinter Review
using LoadDirsIntoArray [Checkin: Comment 7] (813 bytes, patch)
2009-01-29 07:42 PST, Ted Mielczarek [:ted.mielczarek]
benjamin: review+
jaas: review+
mbeltzner: approval1.9.1-
mbeltzner: approval1.9.1.2+
Details | Diff | Splinter Review

Description Ted Mielczarek [:ted.mielczarek] 2009-01-26 11:30:44 PST
Created attachment 358878 [details] [diff] [review]
append $profile/plugins to NS_APP_PLUGINS_DIR_LIST

Currently we don't load plugins from $profile/plugins. It's not generally a problem, but I'm trying to run Mochitest on a packaged build, and nowadays that means we need the test plugin to run all the tests, but there's no easy place to put it. If we support $profile/plugins then I can get it in the Mochitest profile, and all is good.
Comment 1 Josh Aas 2009-01-28 23:56:59 PST
Comment on attachment 358878 [details] [diff] [review]
append $profile/plugins to NS_APP_PLUGINS_DIR_LIST

Why can't you just use LoadDirsIntoArray like above the code you added?
Comment 2 Ted Mielczarek [:ted.mielczarek] 2009-01-29 05:22:31 PST
I could, but that takes an nsCOMArray<nsIFile>, so I'd have to create one. I can give it a shot and see if it's more or less lines of code.
Comment 3 Benjamin Smedberg [:bsmedberg] 2009-01-29 06:08:29 PST
LoadDirsIntoArray does something entirely different. It doesn't make sense to use it here.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2009-01-29 07:42:01 PST
Created attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

Actually, it turns out to be pretty straightforward to do it that way. It's slightly less code, too, and it actually looks more consistent with the surrounding code to me.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2009-01-29 08:02:48 PST
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

Alternate approach. Thoughts?
Comment 6 Benjamin Smedberg [:bsmedberg] 2009-01-29 08:09:20 PST
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

It feels a bit odd, but I guess it's less code.
Comment 7 Ted Mielczarek [:ted.mielczarek] 2009-02-02 06:02:17 PST
Pushed:
http://hg.mozilla.org/mozilla-central/rev/dbe9086219a6
Comment 8 Ted Mielczarek [:ted.mielczarek] 2009-05-12 05:14:13 PDT
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

Want this on branch to unblock bug 383136.
Comment 9 Mike Beltzner [:beltzner, not reading bugmail] 2009-05-12 11:35:58 PDT
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

a191=beltzner
Comment 10 Ted Mielczarek [:ted.mielczarek] 2009-05-14 15:54:59 PDT
Trying to figure out a way to test this, can't really use the test plugin because that already exists in the app plugins dir.
Comment 11 Mike Beltzner [:beltzner, not reading bugmail] 2009-05-27 15:59:45 PDT
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

Revoking approval. We're cutting back on potential churn here. We can try again for 3.5.1
Comment 12 alice nodelman [:alice] [:anode] 2009-06-10 17:25:26 PDT
The ability to load plugins through the profile would be of great benefit to talos.  bug 483902 would (will) be fixed by upgrading flash.  Doing so on all the active talos boxes would take a good long downtime and lots of manpower, being able to roll out new plugins through the profile means that it can be upgraded on the buildbot master and automagically pushed to all the slaves.

I would really like to see this on 1.9.1.  It would also be useful on Firefox3.0, but I can understand why backporting might be considered not valuable enough for the effort.
Comment 13 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-06-18 19:54:23 PDT
Totally understand the "no churn" comment.

However, nom-ing for 3.5.x because we'll need this landed on mozilla-191 before we can stop running build-and-unittest, and only run unittests on packaged builds. And all the resulting yummy goodness that gets us.
Comment 14 Ted Mielczarek [:ted.mielczarek] 2009-06-30 11:07:36 PDT
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

Can we get this on the branch to fix the packaged unittest builds from being perma-orange? It's baked on trunk for a long, long time.
Comment 15 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-07-20 09:44:24 PDT
Who can approve and land this on 1.9.1? 

Its blocking rollout of tp4 on that branch, which is blocking turnoff of fast talos machines on that branch.
Comment 16 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-07-22 17:34:01 PDT
(In reply to comment #15)
> Who can approve and land this on 1.9.1? 
> 
> Its blocking rollout of tp4 on that branch, which is blocking turnoff of fast
> talos machines on that branch.

beltzner, sam: are these flags correct for requesting approval to land test changes on mozilla-191?
Comment 17 Mike Beltzner [:beltzner, not reading bugmail] 2009-07-22 17:52:44 PDT
Comment on attachment 359514 [details] [diff] [review]
using LoadDirsIntoArray
[Checkin: Comment 7]

a1912=beltzner
Comment 18 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2009-07-22 18:03:14 PDT
(In reply to comment #17)
> (From update of attachment 359514 [details] [diff] [review])
> a1912=beltzner

beltzner: cool, thanks.

ted: any chance you can land this, even though you are at OSCON this week?
Comment 19 Dave Townsend [:mossop] 2009-07-22 22:47:04 PDT
Fixed on 1.9.1: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/06bca4693d14
Comment 20 Serge Gautherie (:sgautherie) 2009-07-23 00:01:38 PDT
(In reply to comment #16)
> beltzner, sam: are these flags correct for requesting approval to land test
> changes on mozilla-191?

You might want approval (or wanted) but probably not blocking on 1.9.0.x.
Comment 21 Kevin Brosnan 2009-07-30 11:51:31 PDT
Verified
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090730 Minefield/3.6a1pre

Note You need to log in before you can comment on or make changes to this bug.