Notification for a failed or successful update is hidden by the main window

VERIFIED DUPLICATE of bug 311614

Status

()

--
minor
VERIFIED DUPLICATE of bug 311614
10 years ago
10 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

1.9.1 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9) Gecko/2008052906 Firefox/3.0

If one of your updates fails, the notification dialog pops-up after Firefox is restarted automatically. This dialog is placed behind the main window which makes it hard to see that something failed. Even with the flashing task bar button. We should show the dialog in-front of the browser window.

Steps:
1. Download a former Firefox version
2. Start the update and close Firefox manually afterward
3. Modify the update.mar file to make it unusable
4. Start Firefox

With step 4 the updater wants to apply the downloaded update but will fail. The current version of Firefox comes up and before the main window is opened the dialog with the update error is displayed and gets hidden immediately.

Users can miss that something went wrong during the update.
Same is true for the update success notification which Firefox turns off by default... morphing
Summary: Notification for a failed update is hidden by the main window → Notification for a failed or successful update is hidden by the main window
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311614
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.