Closed Bug 475897 Opened 11 years ago Closed 11 years ago

imgIContainer.idl changed without changing uuid

Categories

(Core :: ImageLib, defect, P1, major)

x86
All
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: pjemen, Unassigned)

References

Details

(Keywords: verified1.9.1)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5 XPCOMViewer/1.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081210 Thunderbird/3.0b1

new methods in imgIContainer 
  [noscript] void setDiscardable(in string aMimeType);
  [noscript] void addRestoreData([array, size_is(aCount), const] in char data, in unsigned long aCount);
  [noscript] void restoreDataDone();


Reproducible: Always

Actual Results:  
old uuid 

Expected Results:  
new uuid
Flags: wanted-thunderbird3?
Component: General → ImageLib
Flags: wanted-thunderbird3?
Product: Thunderbird → Core
QA Contact: general → imagelib
We need to rev this.
Blocks: 296818
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.1?
On the other hand, we already shipped 1.9.0 with the old iid, right?  It's not clear that we want to rev on the stable branch.  :(
Yeah, I'd rather not rev on 1.9.1 if we didn't rev on 1.9.0.  1.9.0's been out there and this hasn't hurt anyone yet, so doesn't make sense to tickle that again.  Reopen if you disagree :)
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: blocking1.9.1? → blocking1.9.1-
Resolution: --- → WONTFIX
This was filed because its tickling someone trying to write a Thunderbird extension.

See also the thread on .platform, where the consensus seems to be to rev for 1.9.1 but not on 1.9.0.

Which means this needs to block b3.
Status: RESOLVED → REOPENED
Flags: blocking1.9.1- → blocking1.9.1?
Resolution: WONTFIX → ---
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
Pushed http://hg.mozilla.org/mozilla-central/rev/39e48052f4e9 and http://hg.mozilla.org/releases/mozilla-1.9.1/rev/8557dba227b5
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Seeing as there hasn't been any discussions about this bug for 2 months, I'm guessing there aren't any residual issues. I'm moving this to verified as a result. If anyone has any qualms, feel free to bring them up.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.