Closed Bug 4760 Opened 23 years ago Closed 23 years ago

[PP] Unix: smart quotes drawn way too far above the line

Categories

(Core :: Layout, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cpratt, Assigned: erik)

References

()

Details

(Whiteboard: July 7: Investigating)

If you view something with smart quotes in it under linux, the quotes themselves
are drawn about one line too high on the screen. The URL above contains a simple
text case that shows it very well.
Assignee: troy → kipp
Given it's a Linux only problem, I can't diagnose it
Assignee: kipp → erik
We aren't rendering \u2019 properly...its a unicode font issue...
Status: NEW → ASSIGNED
Target Milestone: M5
I know what the problem is, but we won't be able to fix this soon. Target M5.
Summary: Linux only: smart quotes drawn way too far above the line → [PP]Linux only: smart quotes drawn way too far above the line
Summary: [PP]Linux only: smart quotes drawn way too far above the line → [PP] Unix: smart quotes drawn way too far above the line
Target Milestone: M5 → M6
I need to fix a couple of crashers for M5. This bug is not as important as the
crashers... Marking M6.
Target Milestone: M6 → M7
*** Bug 6235 has been marked as a duplicate of this bug. ***
Target Milestone: M7 → M8
This problem still occurs in the June 30th Linux build.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Fixed by disabling the smart quotes in large Asian fonts. The smart quotes and
other CP1252 characters will be dealt with in bug 454. Currently, those chars
don't display at all.
QA Contact: petersen → cpratt
Whiteboard: July 6: Unix build busted
Whiteboard: July 6: Unix build busted → July 7: Investigating
Status: RESOLVED → VERIFIED
Quotes are no longer displaying. Checked the 1999070908 build under RH Linux
6.0. Marking verified fixed.
You need to log in before you can comment on or make changes to this bug.