Closed Bug 476149 Opened 11 years ago Closed 11 years ago

make unit tests work again on comm-central

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: kairo)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

comm-central build have stopped doing unit tests properly while still calling them correctly from mozilla/

This happened since bug 475111 landed.
The basic problem seems to be that in the main Makefile the subdirectories to be called are set through TIERS and tier_*_dirs which are actually set in build.mk.
As long as rules.mk was converting TIERS to DIRS, that worked fine with the current placement of that include, but since I landed the port of bug 466486, this is done in config.mk already, so we need to move the build.mk inclusion before the one for config.mk now. autoconf.mk needs to be included even before that or MOZ_BUILD_APP isn't set.

I'm running into a problem in testing this right now, suddenly normal "make" wants to enter the installer/ subdir and breaks.
Assignee: nobody → kairo
Status: NEW → ASSIGNED
We also need to set an empty default target at the beginning of the Makefile or we enter the "installer" target that happens to be the first defined one (in build.mk).

This all closely mirrors what the main Mozilla Makefile is doing, by the way.
Attachment #359738 - Attachment is obsolete: true
Attachment #359740 - Flags: review?(bugzilla)
Depends on: 466486
Comment on attachment 359740 [details] [diff] [review]
set TIERS before calling config.mk

r=me based on inspection, lets see how this goes.
Attachment #359740 - Flags: review?(bugzilla) → review+
Pushed as http://hg.mozilla.org/comm-central/rev/1360769469ea
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.