Session restore on 1.9.1 branch (and maybe trunk) incorrectly restores state of some Google Reader elements

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Session Restore
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Misak Khachatryan, Assigned: Simon Bünzli)

Tracking

({regression, verified1.9.1})

3.5 Branch
Firefox 3.6a1
regression, verified1.9.1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
Created attachment 359753 [details]
problematic sessionstore.js example 

When Firefox 3.1 restores Google Reader page, SELECT HTML element for selecting folders on the left of search is always restores expanded.

Steps to reproduce.
1. Open google reader page, read something and close firefox. You should have set option to restore last state in ff preferences.
2. Open Firefox again and it's restores reader page with Select folder expanded.

Same result for Seamonkey 2.0 trunk (also mozilla 1.9.1), to which i'm porting sessionstore. Firefox 3.0 works correct.

I don't thinks that's sessionstore problem, but i'm not sure, so it's worth to check and then triage.
(Assignee)

Updated

9 years ago
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Created attachment 359783 [details]
problematic session pretty-print
(Assignee)

Comment 2

9 years ago
Created attachment 359799 [details] [diff] [review]
don't dispatch input events when the default value didn't change

The issue is that Google Reader reacts to input events which we dispatch even for blank textfields (for unchanged text fields to be precise). Since there's really no point in doing so, we can just stop dispatching input events in that case and be done. Tests are included.
Attachment #359799 - Flags: review?(dietrich)
Attachment #359799 - Flags: review?(dietrich) → review+
Comment on attachment 359799 [details] [diff] [review]
don't dispatch input events when the default value didn't change

r=me thanks!
(Assignee)

Updated

9 years ago
Keywords: checkin-needed

Updated

9 years ago
Keywords: regression
Version: Trunk → 3.1 Branch
http://hg.mozilla.org/mozilla-central/rev/b395701ced50
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
(Assignee)

Updated

9 years ago
Attachment #359799 - Flags: approval1.9.1?
Comment on attachment 359799 [details] [diff] [review]
don't dispatch input events when the default value didn't change

a191=beltzner
Attachment #359799 - Flags: approval1.9.1? → approval1.9.1+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/ed64d408b4e2
Keywords: checkin-needed → fixed1.9.1
verified FIXED on builds:


Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090514 Minefield/3.6a1pre ID:20090514031229

and

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090514 Shiretoko/3.5b5pre ID:20090514031203
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.