The default bug view has changed. See this FAQ.

bookmarks import from IE aborts on hitting a corrupt bookmark

RESOLVED FIXED

Status

()

Firefox
Migration
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: dal765@onetel.com, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Hi, recently I reported and confirmed bug 456956 resolved. And indeed, I can now scroll up and down the Bookmarks list in 1 column.

However, the list is incomplete. The column is longer than one screen, and so scrolls up and down. But about 2/3 are missing. If I look at 'Manage Bookmarks', there is nothing beyond hxxxxxxx.

By comparison, the plugin 'Plain old Favourites' sees them all - at least, it looks like all.

I'd say there are about 4 or 5 columns worth of favorites, mostly folders, some individual ones.

IE7, Maxthon 2, XP PRo.



Reproducible: Always

Steps to Reproduce:
1. Install FF3.05
2. Import IE Favorites
3. View them



IE7, Maxthon 2, XP PRo.

A number of FF plugins.
can you provide (also by mail) an html export of your ie7 bookmarks?
not enough informations to reproduce, please provide the file to import by mail if you want for someone to look into this
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
Hello, I will endeavour to do so.

Meanwhile, using 'Plain Old Favourites' means I can keep a single favorites folder between IE7 and FF, as I understand it.

What I dislike is that this means scrolling vertically through a long list, which is cumbersome. I believe that was the behaviour in FF too.

Maxthon's multi column approach is MUCH friendlier. Would really like to see this in FF.

IE7 uses the vertical scroll presentation.
Resolution: INCOMPLETE → FIXED
Resolution: FIXED → INCOMPLETE
(Reporter)

Comment 4

8 years ago
Created attachment 375468 [details]
Screenshot, normal mode
(Reporter)

Comment 5

8 years ago
Created attachment 375469 [details]
Screenshot, safe mode, scrolled to limit (HTT)

Herewith two screenshots showing IE imported favourites scrolling at the limit, latest FF in Vista SP1. The rest - more than half- are inaccessible by this means.

Plain old favourites add-in allows me to access all.

I have sent a set of favourites as requested by email.

Hope that lets you investigate or advise.

Thanks David Lawrie
(Reporter)

Comment 6

8 years ago
Hi, perhaps this is actually a problem in importing the list of favourites.. could the import be curtailed for some reason?

I've not tried exporting and the file isn't directly accessible.
Resolution: INCOMPLETE → FIXED
(Reporter)

Comment 7

8 years ago
Ok, I've identified the problem for you.

There's an improperly formed shortcut in the list.

Either:
- the import process fails when it encounters this
Or:
- the display terminates when the shortcut is encountered.

Its URL is 
http--www.fco.gov
Resolution: FIXED → WONTFIX
(Reporter)

Comment 8

8 years ago
Created attachment 375474 [details]
Problem improperly formed URL shortcut

When this is encountered, action should be at least to ignore it, preferably warn.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
yes, a corrupt bookmark entry in IE could cause import to fail in the middle. Moving to migration.
Component: Bookmarks & History → Migration
QA Contact: bookmarks → migration
Summary: 2/3 of freshly imported bookmarks missing → bookmarks import from IE aborts on hitting a corrupt bookmark

Updated

7 years ago
Duplicate of this bug: 494867

Updated

7 years ago
Duplicate of this bug: 580391

Updated

7 years ago
Depends on: 575591

Comment 12

7 years ago
This should be addressed by the patches in bug 575591.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.