Closed Bug 476277 Opened 15 years ago Closed 8 years ago

Degraded look for large dropdowns since bug 399030

Categories

(Core :: Widget: Cocoa, defect)

All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mstange, Unassigned)

References

Details

(Keywords: regression, Whiteboard: rdar://6588996)

Since bug 399030 we're using NSPopUpButtonCell to draw dropdowns. However, those don't look as good for large heights: Unlike Carbon kThemePopupButton buttons, NSPopUpButtonCells don't adapt to arbitrary heights, so we have to scale them manually which leads to a degraded look.

See attachment 357339 [details].
Blocks: 399030
So is there a way to enhance the display of NSPopUpButtonCell with a large height?
I don't think so.
I've created an apple feature request. Let's see what happens.
Whiteboard: rdar://6588996
Assignee: joshmoz → nobody
Cannot reproduce... check the drop down look for Bugzilla, zoom/in/out etc...
If I have misunderstood, feel free to reopen
Version 	47.0.1
Build ID 	20160623154057
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.