Tabs aren't restored after restarting Firefox

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: italiagangsta592, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [worksforme?], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

When I download a theme from the site, as always, I have to restart Firefox for the theme to be applied, which is what I'm used to. But, it tells me that Firefox will try to restore the tabs I had open before it closed. However, this does not happen, and I just go to my homepage. I have to go back to all my sites again, and my tabs are gone.

Reproducible: Always

Steps to Reproduce:
1.Go on https://addons.mozilla.org/en-US/firefox/browse/type:2
2.Download any theme or add-on.
3.See if Firefox restores your tabs when it opens back up.
Actual Results:  
The tabs weren't restored.

Expected Results:  
It should have restored the tabs I had before I restarted Firefox.

It's not just one theme that does it, it's all add-ons and themes, because I tested it many times.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.1 Branch
Please try this on the latest branch build, available at ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-1.9.1/ . This works fine for me. When trying out the build please try it out on a clean profile http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile .
Component: Tabbed Browser → Session Restore
QA Contact: tabbed.browser → session.restore

Comment 2

10 years ago
My bet would be that you're clearing private data at shutdown (making this a DUPE of bug 398817).
Whiteboard: [worksforme?]
(Reporter)

Comment 3

10 years ago
Yup. Thanks Simon, that's exactly what it was. You guys are the best!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.