Closed Bug 476684 Opened 11 years ago Closed 9 years ago

window.resizeBy and window.resizeTo doesn't take full page zoom into account

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 547469

People

(Reporter: szabo.daniel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

When full page zoom is active window.resizeBy and window.resizeTo should multiply their arguments by the zoom factor. window.innerWidth and innerHeight report values that take the zoom factor into account. This way it's not possible for a script to control window size.

Reproducible: Always

Steps to Reproduce:
Activate full page zoom. Use window.resizeTo() to resize the window to a given size.
Actual Results:  
The window's physical size will match the arguments given to window.resizeTo. window.outerWidth/outerHeight will report values less by the zoom factor.

Expected Results:  
The window's physical size should match the arguments multiplied by the zoom factor.

The actual problem is the inconsistent behavior of the getter and setter methods. For instance, Opera reports actual window sizes even if full page zoom is active. The most transparent solution for scripts would be that both the setter and getter methods take the full page zoom factor into account.
Component: General → DOM: Core & HTML
Product: Firefox → Core
QA Contact: general → general
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547469
You need to log in before you can comment on or make changes to this bug.