Opening new browser windows is incredibly slow

VERIFIED DUPLICATE of bug 49141

Status

defect
P3
normal
VERIFIED DUPLICATE of bug 49141
19 years ago
15 years ago

People

(Reporter: shoe_adam, Assigned: asa)

Tracking

({perf})

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; m18) Gecko/20000804
BuildID:    2000080404

If a blank window is opened, it takes 8sec to appear and be usable.  If either
the new window, or the old window are rendering a page, this jumps up to
14-19sec.  If they are both rendering, it ends up being 26sec for either window
to become usable.

Reproducible: Always
Steps to Reproduce:
1.have a window open
2.open a new one


Actual Results:  depending on the amout of rendering going on, it takes way too
long for Mozilla to return to a usible state.

Expected Results:  I would expect windows to be usable almost imedieatly


I am using a 266 G3 iMac, w/ 96Megs of RAM.

Comment 1

19 years ago
Added perf keyword.  Can't confirm b/c my machine is better endowed :)
Keywords: perf
(Reporter)

Comment 2

19 years ago
there should be a "d" in rendering.  oops.

Summary: opening renering windows is incredably slow → opening rendering windows is incredably slow
Could be considered dogfood for people who routinely command-click on links.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: opening rendering windows is incredably slow → Opening new browser windows is incredibly slow

Comment 4

19 years ago
Isn't this really a dupe of bug #7672?
(Assignee)

Comment 5

19 years ago
I believe that 7672 concerns the time it takes for the open new window
functionality to become available after opening a new window and this bug is
about the total time it takes to open a new window.  I think but am not sure
that you can open a new window before the first window has finished opening.
That would make these two bugs different.  I'm unable to test this reliably
because my new windows take less than 2 seconds to appear.
Marking duplicate of a newer bug, because the other bug has more favorable status 
whiteboard contents.

*** This bug has been marked as a duplicate of 49141 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
yep, dupe of (49141). verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

15 years ago
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.