Closed Bug 47689 Opened 20 years ago Closed 19 years ago

ftp password dialogbox cannot be localized into non English.

Categories

(Core :: Internationalization, defect, P3)

DEC
All
defect

Tracking

()

RESOLVED INVALID
mozilla0.9.1

People

(Reporter: ftang, Assigned: dougt)

References

()

Details

(Keywords: l12y)

Attachments

(2 files)

use localized build (ja/fr/de) visit ftp://ftang@sweetlou/
 

Expect result-
The dialog title should show localized translation of "Password" and the dialog 
text show localized into local language in localized build.

Actual result-
The dialog title show "Passowrd" and 
I see "Enter password for "  and/or "Enter username and password for " in 
English 


the problem is in the following code
netwerk/protocol/ftp/src/nsFtpConnectionThread.cpp
827             message.AssignWithConversion("Enter username and password for 
"); //TODO localize it!
828             message.AppendWithConversion(host);
829 
830             nsAutoString realm = NS_ConvertToString(host);                   
// XXX i18n 
831             rv = proxyprompter->PromptUsernameAndPassword(nsnull,
832                                                           
message.GetUnicode(),
833                                                           
realm.GetUnicode(), nsIPrompt::SAVE_PASSWORD_PERMANENTLY,
834                                                           &user, &passwd, 
&retval);
835 



AND

902             title.AssignWithConversion("Password");
903             
904             nsXPIDLCString host;
905             rv = mURL->GetHost(getter_Copies(host));
906             if (NS_FAILED(rv)) return rv;
907             message.AssignWithConversion("Enter password for "); //TODO 
localize it!
908             message += mUsername;
909             message.AppendWithConversion(" on ");
910             message.AppendWithConversion(host);
911 
912             nsXPIDLCString prePath;
913             rv = mURL->GetPrePath(getter_Copies(prePath));
914             if (NS_FAILED(rv)) return rv;
915             rv = proxyprompter->PromptPassword(title.GetUnicode(),
916                                                message.GetUnicode(),
917                                                
NS_ConvertASCIItoUCS2(prePath).GetUnicode(), 
918                                                
nsIPrompt::SAVE_PASSWORD_PERMANENTLY,
919                                                &passwd, &retval);


We need to put these string into string bundle so we can localize it and ship a 
localized JA/DE/FR client. 
cvsblame show valeski is around the code. Assign to valeski
localizability issue. nsbeta3
-> gagan
Assignee: valeski → gagan
Target Milestone: --- → M18
robert-- welcome to necko!
Assignee: gagan → rjc
triage team:
we know this is important, but it is such a rare dialog and we have so many
other bug fixes that we are nsbeta3-.  However, we will accept a fix to this, we
just don't have the time to fix ourselves.  Another team might have the time and
can nsbeta3+ it.
Whiteboard: [nsbeta3-]
Hi dougt, welcome to necko :)
Assignee: rjc → dougt
Blocks: 62352
Keywords: l12y
Adjusting keywords.  
Keywords: nsbeta3nsbeta1
Whiteboard: [nsbeta3-]
setting milestone
Target Milestone: M18 → mozilla0.9.1
Changed QA contact to andreasb@netscape.com.
QA Contact: teruko → andreasb
gagan, need a r=
darin, can you sr=
Status: NEW → ASSIGNED
Keywords: patch
I'd suggest you cache the bundleService with the handler so that you don't keep 
creating it each time for each connection[thread] object. Other than that 
r=gagan
Hardware: All → DEC
Thanks for the suggestion, but getting the service is not called the much.  
Usually it is not called at all.
Changing QA contact back to teruko for now.
QA Contact: andreasb → teruko
looks like this one is fixed, but needs review and super-review. 
Fix checked in.  r=neeti@netscape.com. sr=darin@netscape.com
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Verified as fixed in 2001-05-30 JA build.

annac@netscape.com, please test this on French and German build.
QA Contact: teruko → annac
Paul - can you check this out for French - I'll take a look at German
For DE this dialog is now fully localised.  However if you enter an invalid
password and click OK the text in the Warning Dialog (login incorrect) is
unlocalised.  This string is not coming from within the language pack.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'll keep this in the list for today.  Tomorrow it may be too late.
Anna, that text comes from the server.  If the ftp server is localized, you 
should see localized text.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.