Closed Bug 477088 Opened 11 years ago Closed 11 years ago

CPU goes to 100% (tbird/wlightning @96-98%) related to storage.sdb

Categories

(Calendar :: Lightning Only, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 390036

People

(Reporter: jw_smith, Unassigned)

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Thunderbird 2.0.0.19 (20081209)/

Lightning 0.9 build 2009091719
Plaxo 4 tbird beat 1.109

Running:
memo backup
firefox(3.05) w 10 to 12 windows
AVG8.0.233
dell c610 running xp sp2 with 1GB memory (2x512MB)

After connecting my yahoo calendar, I have noticed cpu going to 100%, unable to send mail. My yahoo calendar is below.

https://caldav.calendar.yahoo.com/dav/jw_smith/Calendar/jw_smith

Previously after doing a "hacked" restore of my mail files to recover from a disk deletion, I learned that the "panacea.dat" file could cause the 100% pegging. Deleting this corrected problem at that time.

I have added 256MB of memory to bring total memory to 1GB on dell c610 laptop running xp sp2. Probably not relevant for this bug, but memory was added to see if firefox was running long because of insufficient ram.
 
I have found that by deleting storage.sdb, panacea.dat, localstore.rdf, I can send mail. Currently it seems that I may have to delete both panacea.dat and storage.sdb to correct the situation. CPU utilization returns to "85-95%" idle.

In sequence, I restored a single file and test tbird.
I "restored" storage.sdb and restarted tbird with no problem.
Then I restored panacea.dat and restarted tbird with no problem.
Then I restored localstore.rdf and restarted tbird with no problem.
Theproblem does not seem to reappear. The cpu goes to 100%, but comes down to normal and then I can send mail.

I have 7 mail "accounts". Yahoo, Dummy(copies mail received at yahoo), 
AOL, a 2nd Dummy (copies mail received at Yahoo or Imap), Imap account at 
lunar pages, a 2nd Imap account at Lunar pages, Local Folders

The problem has happened 3 to 4 times over the past 1 to 1-1/2 weeks.

Reproducible: Sometimes

Steps to Reproduce:
1. Get system running, 
2. reconnect online yahoo calendar 
3. wait one to two days.
Product: Thunderbird → Calendar
QA Contact: general → general
Reported this bug 0n 2/5. I said that it has been happening every couple of days. Started tbird this morning and cpu pegged at 100%, tbird at 97%.

The yahoo calendar is blank, ie showing no events. Have screen shots showing the blank calendar and directory sorted by date.
This is the directory listory showing the files that have changed since I submitted this bug on 2/5/09.
I moved storage.sdb to storage.save. Thunderbird now runs "normally", the cpu is no longer pegged and I can send email. I have "lost" the settings for yahoo calendar.

I assume that this issue is really a lightning bug as opposed to thunderbird. I'll try to attach/link it to lightning.

I shut tbird down, move storage.save back to storage.sdb. The cpu again goes to 100% with tbird at 98%. I took a screenshot, the tbird screen is blank, the and tbird utilization is at 90%. 

Ater consuming about 1 minute 37 seconds of cpu time (see screenshot for process explorer), yahoo calendar is back and tbird & lightning are "ok", total cpu utilization is "normal", 5 to 10%.
Attached file copy of storage.sdb
This is a copy of storage.sdb that when I moved it, cpu went to "normal". I shut tbird down and named it storage.sdb again. Restarted tbird, after ~ 1 min 37 seconds of cpu time, the calendar synched and evertyhing was "normal".
Component: General → Lightning Only
QA Contact: general → lightning
This is a known issue involving usage of CalDAV calendars (https) _and_ IMAP/SMTP email (SSL) at the same time.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390036
You need to log in before you can comment on or make changes to this bug.