Mouse wheel scrolls listboxes in page instead of whole page

VERIFIED DUPLICATE of bug 33732

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 33732
18 years ago
18 years ago

People

(Reporter: Chase Covello, Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Any page I view in recent builds (haven't tried older ones) that has a listbox
causes the listbox to scroll when I roll the mouse wheel. Expected behavior is
to scroll the whole page, unless the mouse cursor is in the listbox.
Additionally, if the page has multiple listboxes (try this bug page), the wheel
will scroll whichever one the cursor was in last.
I believe this affects the linux x86 builds also, but I've been away from my
linux box and don't remember.

Comment 1

18 years ago
yeah, i keep getting bitten by this.  will probably go away when listboxes use 
gfx scrollbars...to bryner.
Assignee: joki → bryner
Status: UNCONFIRMED → NEW
Component: Event Handling → XP Toolkit/Widgets
Ever confirmed: true

Comment 2

18 years ago
Dupe

*** This bug has been marked as a duplicate of 33732 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.