[FIX]"ASSERTION: out of bounds" with contentEditable, table, overflow:scroll

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: jruderman, Assigned: bzbarsky)

Tracking

(Blocks: 2 bugs, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 360991 [details]
testcase

WARNING: Someone passed native anonymous content directly into frame construction.  Stop doing that!: file /Users/jruderman/central/layout/base/nsCSSFrameConstructor.cpp, line 7924

###!!! ASSERTION: out of bounds: 'PRInt32(aIndex) >= 0 && aIndex <= l', file /Users/jruderman/central/layout/base/nsChildIterator.h, line 132

###!!! ASSERTION: anonymous nodes should not be in child lists: '!aOldChild->IsRootOfAnonymousSubtree()', file /Users/jruderman/central/layout/base/nsCSSFrameConstructor.cpp, line 12404

Comment 1

10 years ago
the warning was introduced in bug 476087, which hints that this might be dupe of bug 476670
Created attachment 361273 [details] [diff] [review]
Stupid first-letter case...

I hate editor.  :(
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #361273 - Flags: superreview?(dbaron)
Attachment #361273 - Flags: review?(dbaron)
Summary: "ASSERTION: out of bounds" with contentEditable, table, overflow:scroll → [FIX]"ASSERTION: out of bounds" with contentEditable, table, overflow:scroll
Am I correct that all you're changing here is removing the assertion and swapping the order of the then/else?
Yeah, basically.  I'm just avoiding making any seek() calls in the non-XBL case when the index is -1.
Attachment #361273 - Flags: superreview?(dbaron)
Attachment #361273 - Flags: superreview+
Attachment #361273 - Flags: review?(dbaron)
Attachment #361273 - Flags: review+
Comment on attachment 361273 [details] [diff] [review]
Stupid first-letter case...

Ah, the else is now an else if; that's the part I missed.
Pushed http://hg.mozilla.org/mozilla-central/rev/c224a8b5416f
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.